Showing results for 
Search instead for 
Did you mean: 

Cannot parse default value of type 'LocalDateTime' MDK

0 Kudos

Hi everyone!

I am trying to initialize an OData in my mobile application, it returns various bugs i have been fixing, but i ran into a bug that doesnt I can fix and it is as follows:

Property Error: Cannot parse default value '/Date(1577836799999)/' of type 'LocalDateTime'.
<Property Name="due" Type="Edm.DateTime" Nullable="true" sap:required="false" sap:creatable="true" sap:updatable="true" sap:upsertable="true" sap:visible="true" sap:sortable="true" sap:filterable="true" sap:display-format="Date" DefaultValue="/Date(1577836799999)/" sap:label="Due"/>

I have been playing with the "Service Options" and "CSDL Optios" of the service but I can not solve it,
Can someone guide me if this type of error can be solved with some configuration?

I really appreciate your support, Thank you!

I attach the options I have in "Service Options" and "CSDL Optios"



Accepted Solutions (0)

Answers (1)

Answers (1)

Product and Topic Expert
Product and Topic Expert
0 Kudos


CSDL document is not expecting the slash date format of JSON encoding. Other OData clients may also have the same issue when consume this OData service. Suggestion is to change the default date value to XML schema format.