cancel
Showing results for 
Search instead for 
Did you mean: 

BIA Errors when reading more than 2 million records...anyone else see this?

alexander_schuchman
Participant
0 Kudos
97

When we run a query that does a "DBSEL" of more than 2,000,000 records we get the following error.

The DBTRANS is lower based on the same execution via aggregates so that we know it will work using the old OLAP/Aggregates technique.

Wanted to see if anyone else was hitting this same situation and what they did about it.

Diagnosis

The volume of data that is to be read from the BIA server is too large (default value > 2,000,000 records). To avoid negatively impacting other users and the stability of the BIA server, this data is not delivered back to the BA system, but instead there is a termination.

System Response

Procedure

Navigate back, add additional filter conditions to further restrict the result, and execute the navigation step again.

If this is not possible, notify your system administrator and request that the database is used for this query instead of the BIA.

Procedure for System Administration

Notification Number RSD_TREX 138

-Alex

Accepted Solutions (1)

Accepted Solutions (1)

Vitaliy-R
Developer Advocate
Developer Advocate
0 Kudos

Hello Alexander,

I think SAP recently lowered threshold that was 3,000,000 records before. And still this is customizable parameter, so you can set whatever you want, it is just that you can cause memory problems in BIA or OLAP (which you say would not rather occure).

Even if you allow reading 2mio++ records to be read from BIA, what time it would take to you to transfer this data set back to BI? Did you check your RFC transfer ratio?

So, may be the best would be to start with why would you need to transfer this number of records and then think about other solution (Open Hub, RSDRI, switch off this query from BIA usage)?

Regards,

-Vitaliy

alexander_schuchman
Participant
0 Kudos

This is the OLAP/DM stats tables loaded into BI and then we're running quarterly utilization reports to see which reports/users are using the system...and what types of response times we're getting.

This is just one example, which obviously is very IT centric but BIA still responds well when it doesn't hit the limit.

Where can you change this limit(just for my info), not that I'm planning to change it.

-Alex

Former Member
0 Kudos

Hello Alexander,

You can change this limit by adjusting the parameter "max_result_size_merge" in the section "OLAP" of the configuration file TREXIndexServer. You can check note 1002839 for more information.

But, if this is the only query where transfer of this huge amount of data is taking place, then it would be better to turn off only this query from BIA rather than changing the above parameter.

Regards,

Praveen

Answers (0)