cancel
Showing results for 
Search instead for 
Did you mean: 

Applying filter to WEBI Column Chart doesn't work

Former Member
0 Kudos
339

Hi All

I have problem achieving the desire result for a WEBI Column chart after applying a variable (measure),  please see attached illustration.

Notice that if just display a dimension Proj Mp Org and variance (measure),  even for WEBI table,  application of filter doesn't work

Is this a bug ?  any workaround

Thank you

Accepted Solutions (0)

Answers (2)

Answers (2)

arijit_das
Active Contributor
0 Kudos

This is because the variance is getting aggregated in your chart as you have used only Proj Mp Org dimension in chart.

You need to create a new measure variable as below and use it in chart:

v_VarianceForChart =Sum(If([Variance]<0;0;[Variance]) In ([Proj Mp Org];[Project Org]))

No need to apply any filter to the chart.

Former Member
0 Kudos

Hi Arijit Das,  I had created the new measure variable and apply to the chart but still didn't filter off negative variance in summation

For your further advice,  please.

Thank you

Former Member
0 Kudos

Hi all

It is a typo mistaken in my formula,  it works !!!  Great and thanks for all

Have a nice day !!

former_member207878
Active Participant
0 Kudos

When you are trying to include filter with condition Variance>0, then it is checking overall Variance value i.e. 5.89, which is greater than 0. that's why it is displaying result as 5.89 in chart.

Just try to modify your condition by including one more dimension in filter or You can make one more variable, which will only take positive values and display that variable in chart.