Showing results for 
Search instead for 
Did you mean: 

#ABAP_Trial - Installation of SAP NetWeaver 7.52 SP04 TestDrive fails with Segmentation Fault

0 Kudos

I tryed to install the software on openSUSE Leap 15.4, which is the current available distribution. I made several approaches, using VMWare Player 17 and VirtualBox 6.1, both with 2, 3 and 4 Processors and 6, 8 and 16GB RAM. I Installed openSUSE following Julie's instructions, and also tried to setup the system on an OS with Gnome desktop as well as a pure server installation. The following installation results were in each case the same.

The first run of the script failed, because the original license file is expired. I replaced the original file /sybase/NPL/SYSAM-2_0/license/SYBASE_ASE_TestDrive.lic with the one from the License.rar file and renamed it to SYBASE_ASE_TD.lic as described in the readme.txt file.

After a reboot I started the installation again. This time I got to the point with the INFO message syb_start_db_server_reset_sa_password.
Here the installation process doesn't continue. In the log file/sybase/NPL/ASE-16_0/install/NPL.log I found following message:

00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  Address 0x0x00007f4ce4089410 (), siginfo (code, address) = (2, 0x0x00007f4ce4089410)<br>00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  **** Saved signal context (0x0x000000014b24a740): ****
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  uc_flags: 0x7, uc_link: 0x(nil)<br>00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  uc_sigmask: 0x7bfbf037 0xb 0x2 0xe4089410
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  uc_stack: ss_sp: 0x(nil), ss_size: 0x0, ss_flags: 0x2
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  General Registers (uc_mcontext.gregs):
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	PC : 0x00007f4ce4089410 ()
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel          RAX : 0x00007f4ce4089410  RBX : 0x00007f4ce400c3b0
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel          RCX : 0x0000000000000003  RDX : 0x00007f4ce4143830
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	RBP : 0x000000014b24bf70  RSP : 0x000000014b24b428
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	R8  : 0x0000000000000002  R9  : (nil)
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	R10 : 0x0000000000000001  R11 : 0x00007f4cf10a7afe
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	R12 : 0x00007f4ce4089410  R13 : 0x00007f4ce40022c0
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	R14 : 0x000000014b24b9b0  R15 : 0x000000014b24b9a0
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	RDI : 0x00007f4cf1d8b5c0  RSI : 0x00007f4ce4093d70
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	RIP : 0x00007f4ce4089410  CSGSFS : 0x002b000000000033
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	TRAPNO : 0x000000000000000e  ERR : 0x0000000000000015
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  	EFL : 0x0000000000010202
00:0002:00000:00000:2023/01/10 10:51:26.70 kernel  **** end of signal context ****
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x00000000015240c0 pcstkwalk+0x482()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x0000000001523a7f ucstkgentrace+0x20f()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x00000000015202b2 ucbacktrace+0x54()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x00000000017ee7fc terminate_process+0x1a1c()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x000000000155078c kisignal+0x706()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x00007f4ce4089410 ()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x00000000021a2f1b Snap::Validate()+0x3b()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x0000000001828f5d SnapValidation+0xfd()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  pc: 0x00000000008d70e6 dsinit+0x1776()
00:0002:00000:00000:2023/01/10 10:51:26.71 kernel  end of stack trace, kernel service process: kpid 1114121
00:0001:00000:00000:2023/01/10 10:53:26.70 kernel  Warning: The internal timer is not progressing. If this message is generated multiple times, report to SAP Technical Support and restart the server (alarminterval=0).
00:0001:00000:00000:2023/01/10 10:59:46.70 kernel  Adaptive Server had 197078 major and 2143 minor page faults since boot, and 197078 major and 2143 minor page faults in last 500000 milliseconds.

This message is always the same, no matter which hypervisor I use nor how many processor cores or RAM I provide.

I also found in /tmp/sapinst_instdir/NW73/SBC/STANDARD/sapcontrol.<n>.log following message:

10.01.2023 10:50:55


FAIL: NIECONN_REFUSED (Connection refused), NiRawConnect failed in plugin_fopen()

Might this cause the following segmentation error?

I'm currently running out of ideas, what else I could check or modify to get one step further.

I appreciate very much any kind of help, which could point me into a direction which would guide me to solve this issue.

Some remarks to the OS installation:

Although the installation guide says that its recommended to provide a swap space of 8GB, I saw in the
screenshots that the swap drive on both Hypervisors was left at 2GB. That's what I did as well.

The C-shell isn't installed by default in openSUSE. I installed it via commandline with

 sudo zypper install tcsh

Also uuidd was installed from the commandline with

 sudo zypper install uuidd

and started before running the install process with

 sudo service uuidd start

Thanks in advance for any kind of support!

0 Kudos

Just wanted to thank you for your reply - adjusting the script for kernel versions >5.4 worked well.

Accepted Solutions (0)

Answers (0)