Showing results for 
Search instead for 
Did you mean: 

500 Internal Server Error : java.lang.NoClassDefFoundError in XI - SLD

Former Member
0 Kudos

Hi Friends,

We have upgraded the NW2004s java sp level from SP 04 to SP 05. But after doing so we are getting the following error while accessing the System Landscape Directory from the following link


The error description is as below

"500 Internal Server Error

Web Dynpro Container/SAP J2EE Engine/6.40

Failed to process request. Please contact your system administrator.

Error Summary

While processing the current request, an exception occured which could not be handled by the application or the framework.

If the information contained on this page doesn't help you to find and correct the cause of the problem, please contact your system administrator.

Root Cause

The initial exception that caused the request to fail, was:

java.lang.NoClassDefFoundError: com/sap/lcr/pers/jdbc/CRQMappedJdbcJ2EEPoolPersistence






... 28 more

Correction Hints

It can't be determined from the exception chain, which class loader failed to load the above class. But at least the class loader of the current application does not contain a resource with name 'com/sap/lcr/pers/jdbc/CRQMappedJdbcJ2EEPoolPersistence'.

If I click on the SLD onthe SAP Netweaver - Exchange Infrastructure, I am getting the above error.

Pls help me to solve this problem.

Thanks in advance


View Entire Topic
Former Member
0 Kudos


Ref this

Former Member
0 Kudos

Hi Sridhar,

Thanks a lot for your reply.

I can launch the transaction SXMB_IFR. It works fine. I got the XI frontend with Exchange Infrastructure Tools.

But when I click on the SLD I am getting this error.

I have also tried to open the http://<SLDserver>:<port>/sld link. But this is also giving me the same error.

I have checked the SLDCHECK transaction.

I am copy/pasting some part of the Check result for reference.

""Use transaction SLDAPICUST if you wish to maintain the SLD server access data

Launching the SLD GUI in a separate browser window...

=> Verify in the browser GUI that the SLD is in a healthy running state!


Retrieving data from the SLD server...

Function call returned exception code 4

=> Check whether the SLD is running!

Summary: Connection to SLD does not work

=> Check SLD function and configurations""

I have checked the following thread

But the solution provided in the thread "configure the hostname without any domain with transaction SLDAPICUST" doen not work.

By the way how to check whether SLD is running or not.

Thanks in advance and warm regards