Showing results for 
Search instead for 
Did you mean: 

0FI_GL_4 delta Init without data transfer not populating BWOM2_TIMEST

0 Kudos

Hi Experts,

I am trying to load FIGL data from ECC to BW4HANA using 0FI_GL_4 extractor. When i run init without data transfer ,the dtp completes successfully but there is no entry in table BWOM2_TIMEST. The subsequent delta extraction failing with error message "Error in Delta Extraction : Datasource 0FI_GL_4".

If i run delta init with data transfer then it pulls all records and i am seeing entry in BWOM2_TIMEST. Could you please help me in understand why delta init without data transfer not populating BWOM2_TIMEST table and not supporting further delta loads?



0 Kudos

Hi Yuvaraj,

As per my experience, AIED (After-Images with Deletion) extractors doesn't allow Init without data transfer.

May be the way AIED works, it is only allowing Init with data transfer.

Accepted Solutions (0)

Answers (1)

Answers (1)

0 Kudos

Hello Yuvaraj,

0FI_GL_4 GL Line items (Minute-based extraction n default is switched off

0FI_GL_6 GL Blances

0FI_GL_1 GL balances, used for direct access, No delta enabled, used for reconciliation and reporting purposes, it will slow the process. reconciliation will be done based on created date.

BWOM_SETTINGS BW extractor settings.

BWFI_AEDAT List of changed documents for use by 0FI_xx_4.

BWOM2_TIMEST List of timestamps of previous deltas for 0FI_xx_4. Use program

BWOM2_TIMEST to view the table contents with the timestamps translated to readable values. This program can also be used to change the delta pointer.

In brief, MBE is switched on and off by using the function module BWOMU_PUT_BWOM_SETTINGS to update the flag BWFINEXT in table BWOM_SETTINGS.

I hope this helps.



0 Kudos

Hi Lakshmi,

Thanks for your comment!

My issues is not related to Minute based Extraction. I have not enabled it.

When i do init without data transfer for 0FI_GL_4 extractor , my expectation is it should create the entry in table BWOM2_TIMEST with update mode (S). But I am not seeing any entry.

When i do init with data transfer , then I am seeing entry in the table with lower and upper timestamp values. But i would like to go for init without data transfer because of huge data volume in source.

Please let me know if you have any idea why the BWOM2_TIMEST table not populating for init without data transfer.