Technology Blogs by SAP
Learn how to extend and personalize SAP applications. Follow the SAP technology blog for insights into SAP BTP, ABAP, SAP Analytics Cloud, SAP HANA, and more.
Showing results for 
Search instead for 
Did you mean: 
0 Kudos


While changing the parameter icm/HTTP/max_request_size_KB , I faced the issue as "SetProcessParameter failed :2 permission denied". 




I did a little digging to understand what it is SetProcessParameter meant. The SetProcessParameter Sets dynamic Profile Parameters for a given process. This is taken care by sapcontrol. So sapcontrol is responsible for taking care of the 'SetProcessParameter'. Now assuming you are changing a dynamic parameter this will be invoked. But when I was trying to change the parameter I was getting the error as SetProcessParameter failed :2 permission denied.

The SetProcessParameter  is a protected webmethod and this is taken care using the parameter service/protectedwebmethods. More more details on which webmethod falls under protected or unprotected please refer this awesome blog Protected web methods of sapstartsrv .


In this we can see the SetProcessParameter comes under the category of 'service/protectedwebmethods = SDEFAULT ' .

When I checked I could see that I was getting the permission denied entry which means I was not calling the parameter SetProcessParameter with the correct settings.


To resolve the issue I set the parameter to  service/protectedwebmethods = SDEFAULT . Post this I took a restart and this resolved my issue.


I was able to change the parameter dynamically. Also I tried this in my other test system ( based on 742 kernel ) which was facing issue. The issue solved in 745 and 749 kernel. I could find this issue in 753 kernel yet. Lets hope it does not feature there 😉


Let me know in case any queries.


Kind regards,

Manjunath Hanmantgad