Technology Blogs by SAP
Learn how to extend and personalize SAP applications. Follow the SAP technology blog for insights into SAP BTP, ABAP, SAP Analytics Cloud, SAP HANA, and more.
Showing results for 
Search instead for 
Did you mean: 
0 Kudos
Some time ago a customer reported these problems / symptoms:

  • unable to start batch files (.bat or .cmd files)

  • problems in transport management

  • tp.exe is not working correctly

  • and more ...

A simple batch script with one line shows NO RESULT (no output) when executed:


echo "hello world"


Several colleagues from SAP support tried to find the needle in the haystack. Even if we execute this sample script via SE38 -> RSBDCOS0 cmd shell, there was no output!

The problem must be located on Windows level.

Root cause:

Somebody "created" a file on the same drive, where the SAP executables are located, for example: E:

The name of this file was "cmd". And the size: 0 bytes! And it had no extension.

We can only guess: Somebody tried to start cmd.exe but somehow "copied" a file with zero bytes to e:\cmd ???


Whenever somebody tried to start "cmd", the OS was looking for cmd (.exe) in the actual search path. The OS found a file called "cmd" and because this file had no extension (.exe), it asked the logged on user (using RDP session) what kind of file this is and with which application this file should be opened?

Running "cmd" from within the SAP system doesn't show this question, of course.


A simple "run cmd" via RDP session finally revealed the secret. That small mistake caused a lot of problems ...