Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 

We were recently performing regular maintenance, including an OS patching of the SAP BO development server for one of the SoftwareONE customers.

During the patching, some issues were encountered leading to a failure. It was decided to restore the operationability of the application by reverting to the previously backed-up state of the VM back to the patching event, and the Basis team was tasked to bring the application up and do the sanity tests.

The application was able to start but the login to the CMC was denied.


OS: SLES 15 SP 3



Application: BI 4.2 SP8 P6






Enterprise login with Administrator account was not happening.

The logs suggested that the Server Intelligence Agent (SIA) responsible for running the service is getting stooped.




SIDBOBJ.CrystalReports2016ReportApplicationServer has been started.

|32B2388B56794CAEB56BA8F9F43F74F01f|2024 01 09 14:24:22.951|+0100|Information| |==| | |SIA_SIDBOBJ| 8444|  84|PFDBOBJ.CrystalReports2016ReportApplicationServer (Native Process Agent)| ||||||||||||||||||||com.businessobjects.cad.syslog||Server Intelligence Agent: server SIDBOBJ.CrystalReports2016ReportApplicationServer stopped with exit code = 127 (0x7f).

|32B2388B56794CAEB56BA8F9F43F74F020|2024 01 09 14:24:22.953|+0100|Error| |==|E| |SIA_SIDBOBJ| 8444|  83|PFDBOBJ.CrystalReports2016ReportApplicationServer (Process Agent)| ||||||||||||||||||||com.businessobjects.cad.syslog||Server Intelligence Agent: server SIDBOBJ.CrystalReports2016ReportApplicationServer is considered failed because it has stopped 5 time(s) within 60 minute(s). Please restart this server.

Multiple application restarts and OS reboots were taken but all the efforts were in vain as the login to the CMC was still not enabled.



The error code is a generic one and normally it occurs when the connectivity to the CMS DB is broken and the application is unable to fetch the data from the dbo repository of CMS Database to enable authentication.

First point of investigation is to check the connectivity to the CMS DB via the ODBC connector string (for Linux). It may happen that the user responsible for this connection is either expired or  locked because of any other activity.

In this case, we were able to connect to the underlying HANA database using the connection string but still the login was not enabled to the central management console via the CMC url.

Digging further into this issue we observed that the process boe_cmsd was getting terminated after the application was started. This is a mandatory process which is critical to the normal functioning of the CMS. The logs at this point didn’t helped much either.

This led us to the conclusion that the boe_cmsd was corrupted.


In such cases where the boe_cmsd gets corrupted it is recommended by SAP to copy this from any working environment.

Path of the executable: <installdirectory>/enterprise_xi40/linux_x64/boe_cmsd

In this case it was - /usr/sap/DBO/sap_bobj/enterprise_xi40/linux_x64



We copied this from the test environment of this landscape which was working as expected. Post copy when the application was restarted this process appeared to be stable and we were able to login to the CMC using the enterprise Administrator account credentials.


Conclusion: In cases where authentication is not an issue and the SAP BusinessObjects application still doesn't allow login to the CMC then it is important to check the boe_cmsd process running on the Linux server. This service is critical and responsible for allowing login to the central management console.


Labels in this area