Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
Showing results for 
Search instead for 
Did you mean: 
0 Kudos

Recently I was tasked to install SAP Data Services on Linux and while doing so I faced an issue where the installer failed with the error - "Install already in progress"


Application: Business Object Data Services

OS: Linux

Steps to reproduce the error:

  1. Log on as a non-root user
  2. Set the environment variables
  3. Run ./ of the BI installer (IPS in this case)
  4. Enter the install directory
  5. The installer will fail with the error message - "Install already in progress"


I tried the below steps to resolve it but failed:

1. Delete and recreate the installation folder

2. Perform a reboot of the server

I found a few notes and blogs related to this error that pointed towards deleting all files ".mutex" in the /tmp folder. While trying to follow one of the SAP notes 2790905, I found no ".mutex" file in the /tmp folder as no installer was running in parallel or the root user was used to perform a failed installation.

The logs were not helpful at this point as they were directing to an installer running in parallel or failing causing the issue. 

To gather more helpful logs I tried running the trace as follows:

strace -f -o install.out ./ (followed by your normal patch install command arguments)

(note, install.out needs to be written to a location this user has permission to write to. So you might need to run it like so: strace -f -o /tmp/install.out for example)

Once the installer fails, check the install.out file for "mutex" by running the below command

grep mutex install.out

In my case, the output showed that the user was unable to set the "mutex" file due to lack of permission and was assuming that the presence of another such file was preventing this hence the error message read - "Install already in progress"


After setting the correct permission I ran the installer again and this time it moved past the error resulting in a successful installation.




In case anyone comes across this issue and is unable to find any ".mutex" file in the /tmp folder to delete then perform a check on the write permissions of the non-root user being used to perform the installation. The strace command can also be run to ascertain the root cause.

Refer to the note: 2790905 - An install is already running at this location on Linux in BI 4.x while performing update

Labels in this area