Technology Blogs by Members
Explore a vibrant mix of technical expertise, industry insights, and tech buzz in member blogs covering SAP products, technology, and events. Get in the mix!
cancel
Showing results for 
Search instead for 
Did you mean: 
anilsuryavansi
Participant

Remodelling of Advanced DSO works little different. I did not find any content on SCN so writing in this document. I am just sharing steps to activate advance dso to take effect of changes once remodelling id is created. There are plenty of documents that covers how to create / change advanced DSOs so not duplicating.



When any Advance DSO is created and data is loaded to the ADSO; and then later if it requires to remove any field or change partition criteria (like I did - changed the Hash Partition criteria in Advanced DSO); the advanced DSO does not get activated and a message shows as "Remodelling rule <rule number> <dso name> has been created instead of activation".




See below where I tried to change to Advanced DSOs ZGLD_AD24 and ZGLD_AD37 and got below warning messages.



- hash definition has been changed


Remodelling rule 20160822  ZGLD_AD24 has been created instead of activation



- hash definition has been changed


Remodelling rule 20160822  ZGLD_AD37 has been created instead of activation


 


         


Now to run the remodelling rule - go to transaction RSCNV_MONITOR.



         



Here in transaction - you will see all the remodelling rules and their steps will be marked as "Step  not started".


         



Select the Modelling Rule and "Start Request" - this will start the processing and the step status will be changed to "Step  running". Once all the steps completed under one Advanced DSO - it will be active again and step will be marked as "Step  completed successfully".



Following are the steps under the remodelling:


     Checking InfoProvider


     Saving InfoProvider


     Converting InfoProvider


     Activating InfoProvider


     Cleaning up




Once the remodelling job is completed all the steps will be marked green. As in below screen shot - remodelling for ZGLD_AD24 is completed where as ZGLD_AD37 is still running at process of converting infoprovider.



9 Comments
former_member182997
Contributor
0 Kudos

Nice sharing..
Thanks for this doc.

Former Member
0 Kudos
While we run remodelling rule, does aDSO remain offline i.e. users can't report?
former_member238061
Contributor
0 Kudos
Hi,

suppose I developed an ADSO with 10 keys.

Now I have data in it and we need a further key.

I have two questions:

Can I simply move the info object (e.g. plant - used in existing data already) so that it is a key now?

Or do I first have to clean the ADSO? A normal DSO would require this (I tried).

Or is it even better: The ADSO allows and uses the key also for historical data?

 

Thanks a lot for tips

Thomas

 
sucheno
Participant
0 Kudos
Hello, I have deleted a remodeling rule as it was failing continuously.

Now, DSO is not allowing me to activate again unless that remodeling rule is run successfully.

Even deletion of data in DSO and trying to re-activate is also not helping here.

Can you suggest here?

Thanks.
MBurbach
Explorer
0 Kudos
Hi Suchen,

 

once you have deleted a failed remodeling run, you should reset the ADSO to the state as it was before you applied your changes. Then, you might have a chance to reactivate it. If it still doesn't work, create a copy of your ADSO, apply your changes there, activate it, delete the old one and copy the new one with the technical name of the deleted. Of course you have to release all dependencies of the old ADSO (Queries, composite providers, aggregation levels etc.) before you can delete it...

If your ADSO is planning-enabled, you must switch it to "Loading mode" before you change anything on its characteristics and mustn't change to planning mode, unless the remodeling job was finshed successfully
sucheno
Participant
0 Kudos
Hi Maik,

Thanks for your reply.

RSPM_MONITOR  - transaction has the log of all the requests.

There is a pending request which is corrupted. I have deleted that remodeling request and DSO is activated successfully.

Thanks.
angelika_petry
Explorer
0 Kudos
The aDSO is offline. After remodelling the aDSO is available for reporting again.
0 Kudos
Quick update:

Apparently the transaction is now RSMONITOR running program RSCNV_MONITOR.
former_member842652
Discoverer
0 Kudos
Hi experts,

When remodeling my Adso using RSMONITOR all the steps have green light, but when analyzing last step "Cleaning up" I get the following messages "Data target OR_RSK_2P(Active Table) is locked by process {2023-02-20 11:51:51 000001 CET}" and "Step CLEANUP_BACKUP_TABLES failed", it has an error despite the green signal.

How can we repeat this last step, since the system says "Remodeling still pending" when I open my Adso in Eclipse.

Many thanks,

Rui
Labels in this area