Many times, in support projects, we face issues with stuck queues. If there is any issue with same batch of material pulled from different vendors will get stuck in SMQ2. While working in support project I learned one thing. It is important to resolve the issue but it is even more important to analyze the situation and keep business informed.
This blog post explains the simple process of analysis and resolve queue that was stuck due to the same batch of material pulled from the different vendor.
Here’s a scenario how the inbound stuck queue is typically handled in SAP:
issue:
The below SMQ2 queue is stuck due to Deficit of BA Unrestricted-use 2 EA : 10006180 1001 AFS 0000416486
Replicating the issue:
- Transaction SMQ2
- Input stuck queue number.
- Error is raised.
Cause:
Please find the analysis in below scenario.
however, we can see that sufficient stock in MMBE for same batch 0000416486 with two vendors as shown in below screenshot.
This issue is due to PGI stuck because the same batch for a material was picked from two different places in the warehouse and they were assigned for different vendor numbers. The root cause for it is in a customer return that was incorrectly received under vendor number 10000123 consignment stock.
Solution:
As a last resort we need allow just 1 EA instead of 2 to be taken from the vendor no. 10000054 consignment stock via debug LUW.
hence, here removing all the relevant references related to vendor no. 10000054 from below table parameters of BAPI to process the queue.
Below is the screen shot of BAPI:
In this case we are removing references from below table parameters,
ITEM_DATA
HEADER_DEADLINES
HANDLING_UNIT_ITEM
SUPPLIER_CONS_DATA
ITEM_DATA_SPL
Conclusion:
Using the above process, the typical SMQ2 queue failures can be addressed via debug LUW.
This process will help the respective support teams to take the appropriate action once they receive such issue.
Please share if any feedback or thoughts in a comment!
Note: All the images are created by me and these are free to use/share.