Showing results for 
Search instead for 
Did you mean: 

How to avoid material master data migration of inactive materials to SRM

Former Member
0 Kudos

We are replicating material master from R3 4.6b to SRM 5.0 system. Under COMMPR01 , we can see the product status as deleted or locked .

How we can avoid the master data replication of materials which are already flagged as inactive (deletion) in R3.

Pls suggest.



Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Hello Avinash,

You can avoid the replication of inactive materials using a filter in the middleware parameters:

--> In transaction R3AC1 (Business Objects), for object MATERIAL, you have to check "Filter Settings".

In Filter Settings, you specify the table and the field you want to use as filter.

For example, the field you need to filter is MARA-ENTAR (Deactivated).

In transaction R3AC1, if you input as filter table MARA and use the matchcode for field, the ENTAR field does not show.

If you want the field to appear in the matchcode, you need to insert the field in the following tables:

SRM system: SMOFFILFLD table

Backedn system: CRMFILFLD table

Hope this helps you,


Former Member
0 Kudos

Hi Avinash,

You can maintain the filter for respective material master data in middleware parameters. And while maintaining the filter make inactive for all this material numbers.Here in filter you can maintain this.

Reward points if usefull ,


Former Member
0 Kudos


Please try this ->

1) It is possible to use product_id without needing to replicate material masters from R/3 to SRM. For this to work you have to set the flag "Do not check product" in customizing

(see SRM Server > Master Data > Define External Web Services).

We do it like that and it works perfect for us. Only annoyance is, that we have to put leading zeroes in the product_id field.

"Do not check product" is used to avoid product check in SRM (to avoid replicating products into SRM), so they are not checked against SRM product master.

But this is not related to R/3 check.

In a classic or extended classic scenario, SRM will check that this material exists in the backend, especially for the current plant (location), before creating follow on doc.

As you created your catalog item without zeros, I guess SRM is sending this material to R/3 that does not recognize it.

Then you have this error message. Adapt your product IDs to be aligned with R/3 material master.

2) Try to run the report BBP_PRODUCT_SETTINGS_MW, there you select user as SRM instead of CRM and select service product active

3) Did you already checked OSS note 722600 and 366135 ? Also, Check the SAP OSS Notes - 786345, OSS Note 456753. It talks abt the internal and external representation of product ID in catalog and R3 system.

Related useful pointers ->

Hope this will help. Do let me know.


- Atul