cancel
Showing results for 
Search instead for 
Did you mean: 

ARIBA CIG: IDOC number not getting generated.

dhinesh_thirugnanam
Active Participant
0 Kudos

Hi All,

I am trying to send a Purchase order from ECC to Ariba network.

I have configured the IDOCS setup using 15 steps(screenshot) but still IDOC number is not getting generated.

Can you please tell me where am I missing...

Do I need to maintain interface settings too?

Do I need to maintain House bank settings too?

IDOC Setup from SPRO:

PO idoc to Ariba : Do I need to set the following steps only then will the IDOC be generated?

As of now I just need a IDOC number generated for the PO.

Accepted Solutions (0)

Answers (2)

Answers (2)

0 Kudos

Hi dhinesh.thirugnanam!

Were you able to resolve the situation with IDOCS? I'm experiencing the same situation. Although all required configuration in the SAP Ariba Add-on is in place I'm still not able to get an IDOC number. I've even double-checked all the things 'Mehak Vasudeva' mentioned above.

I appreciate you can share what was causing the IDOC number not to get generated in your case.

mehak_02, If you have any additional idea on what else I can review apart from what you mentioned above, I'll appreciate it a lot. JFYI - In my case, I don't even see the output triggered(in green status) under the 'Messages' tab on the PO screen.

Thank you both!

dhinesh_thirugnanam
Active Participant
0 Kudos

Hi Ramiz,

I pretty much did the same steps mentioned by Mehak and it worked.

Try doing some fictious changes and check.

For NACE.Kindly check the below link.

https://answers.sap.com/questions/539916/automatic-idoc-generation-whenever-a-po-is-created.html

Note: did you execute SRT_IDOC?

Thanks,

Dhinesh.T

former_member411680
Discoverer
0 Kudos

Hi Dhinesh,

Typically, below are the configuration steps required for triggering of PO(Material/Goods) IDoc

1. Creation of RFC Destination (this is under 'General Settings' in 'Integration with other SAP Components')

2. WE20 Partner Profile Set up with Basic Type-> ORDERS; Message Type-> ARBCIG_ORDERS; Process Code-> ME10

3. Customer Exits Implementation as per the standard guide

4. NACE Configuration as per the standard guide

5. Maintain 'ORDER_ENABLED' parameter.

Do you see the output triggered(in green status) under 'Messages' tab on PO screen?

If your IDoc isn't generating, please check if all the above configurations are in place.

Also, ensure that the output type used in NACE setup and WE20 partner profile set up are same.

Thanks & Regards,

Mehak