cancel
Showing results for 
Search instead for 
Did you mean: 

The redirect_uri has an invalid domain

wilyereny
Participant
0 Kudos
957

Hi,
The learning path just got updated and the approuter was changed from Standalone to managed, you provide a Troubleshooting guide for a problem but with the Standalone version of the approuter. Im gettin a "The redirect_uri has an invalid domain." error.

I tried adding a redirect uri but I{m not sure if I'm adding the url right.

noname.png

wilyereny_3-1668111468693.png

SAP Extension Suite 

Accepted Solutions (0)

Answers (4)

Answers (4)

VictorNoroc
Explorer
0 Kudos

You can try the OSS note https://launchpad.support.sap.com/#/notes/2864831 

I've configured it as follows:

  "oauth2-configuration": {
    "redirect-uris": ["https://************-risk-management.cfapps.us10-001.hana.ondemand.com**","https://*.cfapps.us10-001.hana.ondemand.com/**"]
},

 

wilyereny
Participant
0 Kudos

wilyereny_0-1668626992635.png

@markushaug  I got this new mistake by changing what you told me and adding the roles configurations

 

VictorNoroc
Explorer
0 Kudos
Hi,
wilyereny
Participant
0 Kudos
markushaug
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi,

you have two "\\" before "\login\callback". Only one should be there.

And you also have "risk-management.approuter" as subdomain. This might be the issue. How did you name your approuter in the mta-file? Could you share the entire file please?

BR,

Markus

wilyereny
Participant
0 Kudos
Thanks fpor your asistance. I just posted the mta as an answer. Please review it and let me know what having ""risk-management.approuter" as subdomain" means.