Showing results for 
Search instead for 
Did you mean: 

mta.yaml is missing the xsuaa resource even though package.json has the required code

0 Kudos

Hello All,

I am on the learning journey CLD200 Manual Deployment , on task 7 when I run the cds add mta , the generated mta.yaml file is missing the risk-management-xsuaa resource. Although my package.json has the required code for xsuaa. I have tried to delete and recreate the MTA but somehow this resource does not get automatically created. Can someone please share some ideas on what I am doing wrong? SAP BTP, Cloud Foundry runtime and environment  @MarL  Screenshot 2023-02-16 161945.png


my Package.json code is below

  "name": "risk-management",
  "version": "2.0.0",
  "description": "Template for the Learning Journey Building side-by-side extensions on SAP BTP",
  "author": "",
  "engines": {
    "node": ">=14"
  "private": true,
  "dependencies": {
    "@sap-cloud-sdk/http-client": "^2.5.0",
    "@sap/cds": "^6",
    "@sap/cds-dk": "^6.5.2",
    "express": "^4",
    "hdb": "^0.19.0",
    "passport": "^0.6.0"
  "devDependencies": {
    "@sap/ux-specification": "^1.102.16",
    "sqlite3": "^5.0.4"
  "scripts": {
    "start": "cds run",
    "watch-risks": "cds watch --open risks/webapp/index.html?sap-ui-xx-viewCache=false"
  "eslintConfig": {
    "extends": "eslint:recommended",
    "env": {
      "es2020": true,
      "node": true,
      "jest": true,
      "mocha": true
    "globals": {
      "SELECT": true,
      "INSERT": true,
      "UPDATE": true,
      "DELETE": true,
      "CREATE": true,
      "DROP": true,
      "CDL": true,
      "CQL": true,
      "CXL": true,
      "cds": true
    "rules": {
      "no-console": "off",
      "require-atomic-updates": "off"
  "cds": {
    "requires": {
        "kind": "odata-v2",
        "model": "srv\\external\\API_BUSINESS_PARTNER",
        "[development]": {
          "credentials": {
        "[production]": {
          "credentials": {
            "destination": "API_BUSINESS_PARTNER"
      "db": {
        "kind": "hana-cloud"
      "xsuaa": {
        "kind": "xsuaa"
  "sapux": [




Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi @former_member124169

We have received your request and are in the process of evaluating the problem.
Please allow for a delay in our response.
Kind regards

Accepted Solutions (0)

Answers (0)