cancel
Showing results for 
Search instead for 
Did you mean: 

Developing with SAP Integration Suite- unable to test Proxy API

former_member14487
Product and Topic Expert
Product and Topic Expert
1,494

Hi all,

I'm following the Learning Journey -Developing with SAP Integration Suite and I cannot test the proxy api
I get the error message - Unable to fetch response. [Request ID: b7ae3935-4689-47f7-a04d-47a9b7001129]
An error occurred while making the HTTP request. 

Everything is set up correctly and I still get this error and as such I can proceed to the rest of the tasks under API Provisioning

I am using the trial version on AWS US East (VA)

 
 
Margit_Wagner
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi @former_member14487
We have received your request and are in the process of evaluating the problem,
Please allow for a delay in our response
Kind regards
Margit

Margit_Wagner
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi @parvez9khan
Thank you for sharing the screenshots.
We keep up to date on the outcome of the analysis.
Kind regards
Margit

 

parvez9khan
Explorer

Hi @former_member14487 @Margit_Wagner @sklawonn 

After updating roles and Grant-types at API Plan instance I was able to test api proxy in console as well as postman.

Thanks to all for your support

parvez9khan_1-1673430433499.png

 

parvez9khan_0-1673430367333.png

Thanks, Parvez

 

Margit_Wagner
Product and Topic Expert
Product and Topic Expert

Hi @parvez9khan.
Thank you for your update and also sharing the solution including  screenshots.
This will help others in future if they run into the same issue.

We appreciate that you use our BTP Learning Group actively and participate in peer-to-peer learning,

Kind regards
Margit

View Entire Topic
former_member14487
Product and Topic Expert
Product and Topic Expert

Hi all, 

This has now being resolved , Thanks to Sebastian.

I recreated the new Proxy api today and tested. The test connection worked at the 3rd try ,

 

 

Margit_Wagner
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi @former_member14487,
We are glad to hear that our technical experts supported you and got this solved.

If this question is answered from your perspective, I also would like to ask you to use function “Accept as Solution" to complete this case.

Kind regards

Margit

parvez9khan
Explorer
0 Kudos

HI @former_member14487 @Margit_Wagner  Can you pls help with steps to resolve this issue? I'm also having same issue with same setup on trail

I've tried by recreating the new Proxy api but no luck

Margit_Wagner
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi @parvez9khan

While we are in the process of evaluating the problem maybe ChiomaN might  weigh-in and share her she solution?
Kind regards
Margit
 

former_member14487
Product and Topic Expert
Product and Topic Expert
0 Kudos

@parvez9khan,  @Margit_Wagner  

Nothing special was done, sometimes the trial version on AWS has performance issues that will not allow the connectivity or tests to work. I got on a call with one of the experts and it worked as expected. Sometime screen sharing does the magic 🙂

As I mentioned I tried the 3rd time, repeating same steps and it worked. I will say try another day, perhaps after a restart and cache cleared, If you want you can ping me on Ms Teams and we look at it together. 

 

 

sklawonn
Product and Topic Expert
Product and Topic Expert
Please retry it til the connection will work. I am talking to our backend Admins to get more details about it. Thank you for your patience.
parvez9khan
Explorer
0 Kudos

@sklawonn @former_member14487 @Margit_Wagner  Here are the screenshots for information while testing API

parvez9khan_0-1672909578795.pngparvez9khan_1-1672909607371.png