SAP for Utilities Discussions
Connect with fellow SAP users to share best practices, troubleshoot challenges, and collaborate on building a sustainable energy future. Join the discussion.
cancel
Showing results for 
Search instead for 
Did you mean: 

BP in ISU is not getting replicated to SD

0 Kudos

Hello Experts,

We are having issues with BP getting replicated from ISU to SD.When the BP gets created , if it is created with MKK role then it is creating customer in SD.If it is created with BUP001 or some other roles system is not creating customer in SD.our issue is with BP which are created with some other roles like BUP001 and then changed on later to MKK role.Even if the role is changed to MKK,still the customer is not getting created in SD side.Because of this users are getting errors when they try to use this BP in orders.Is there anyway we can push the BPs which are converted back to MKK role from some other role to SD?Can you please help

Regards

karthik

1 ACCEPTED SOLUTION

monis_shakeel
Active Participant
0 Kudos

Hi Karthick,

The parameters for automatic creation of SD customers for IS-U BP need to be maintained at the following path firstly.

IMG ----Sap utilities--Master data---Business partner---Settings for Creating Standard Customers---Maintain parameters for creating reference customer in standard system.


For those BP that have already been created without SD customer, you may use the following FM to push creation of SD customers.

ISU_S_PARTNER_CHANGE


Hope this helps.


Regards,

Monis Shakeel

View solution in original post

10 REPLIES 10

monis_shakeel
Active Participant
0 Kudos

Hi Karthick,

The parameters for automatic creation of SD customers for IS-U BP need to be maintained at the following path firstly.

IMG ----Sap utilities--Master data---Business partner---Settings for Creating Standard Customers---Maintain parameters for creating reference customer in standard system.


For those BP that have already been created without SD customer, you may use the following FM to push creation of SD customers.

ISU_S_PARTNER_CHANGE


Hope this helps.


Regards,

Monis Shakeel

0 Kudos

Hi Monis,

I tried with the FM ISU_S_PARTNER_CHANGE but it does not create a entry in SD.I have just passed the BP as input parameter to the FM.It did not create an entry in SD.Am i missing something.Can you please suggest.

Regards

Karthik

0 Kudos

You need to pass the BP, X_NO_DIALOG as 'X' if you need to run this in background and in parameter X_MUSTER_KUN, pass the reference customer.

This should create an SD customer.

Regards,

Monis Shakeel

0 Kudos

Hi Monis,

Thanks for the reply.I gave the inputs to FM as you have mentioned in your previous reply.But i got the error message in the function module "The customer does not exists in KNA1".Can you please suggest.

Regards

Karthik

0 Kudos

Hi Monis,

I did not get any error now while executing the FM.I have updated the partner with reference number and still could not see the customer in KNA1.Can you please suggest.

Regards

Karthik

william_eastman
Product and Topic Expert
Product and Topic Expert
0 Kudos

Karthik:

check/apply note 1781651.  then the user should be able to maintain the reference customer value and save the data.

regards,

bill.

0 Kudos

Hi William,

Thanks for the reply. I checked the note.But the issue we are facing is different.We do not face this issue  for all the customers.We are facing this issue with the  customers which are created with role like BUP001  and then later converted to MKK.These  customers do not replicate to SD initially since they do not have MKK role and when the role is changed to MKK,entry needs to be created in KNA1 table.Can you please suggest is there a way we can pull these customers in KNA1.I tried changing the BP in FPP2.But it did not replicate to KNA1.

Regards

Karthik

0 Kudos

Hi William,

Currently in FPP1 the reference field is enabled.But since the customers with issue is already created, i checked in FPP2,I could not see the reference field for all those customers which are missing in KNA1.Can you please suggest.

Regards

Karthik

0 Kudos

Have you checked your field selection configuration?  Make sure you have enabled the ref cust field in change mode.  But also be careful since now users might try to change it.

0 Kudos

Hi William,

I compared the two BP partners one with  the reference partner maintained during the creation of the BP for the whom the KNA1 entry already exists,I checked in FPP2 for this partner and found the disabled reference partner field.  But if the BP partner is created with out the reference partner then in FPP2 for this partner i could not find the reference partner field.Can you please suggest.is it because of reference partner field not  maintained during the creation of BP?