SAP for Retail Discussions
Join conversations about personalization, omnichannel strategies, and operational excellence in retail using SAP for Retail software.
cancel
Showing results for 
Search instead for 
Did you mean: 

Idocs not sent to SAP ERP Retail

Former Member
0 Kudos
1,405

Hello Forum, i have created a connection between SAP POS DM to SAP Retail. Let me tell you which steps i did.

I created both Outbound and Inbound Ports in We20 for POS DM and also for SAP Retail using WPUBON, WPUUMS, WPUFIb and WPUTAB. When i create a transaction in POSDM and i process all the tasks, the system shows a green flag, but when i check the POS DM Idocs sent in We02 it says that i sent a document using the LS partner and not the KU partner, the exit port is ok, but the partner is not.

Do you have a step by step workaround for the ports? and Pos DM sending idols into sap retail?

Thanks in advance.

Reynaldo

21 REPLIES 21

vikrant_mohite
Active Contributor
0 Kudos
1,015

Hi,

Can you share the screenshot of error.

Thanks,

Vikrant.

0 Kudos
1,015

Hi Vikrant, there is no error. The "error", is that there is no idoc sent to the partner KU if you see the we02.

I'm sending the configuration in order you to see how it is right now.

Greetings,

0 Kudos
1,015

Hi,

Something must be wrong in configuration in POS DM as you do not get IDoc in WE02.

Thanks,

Vikrant.

0 Kudos
1,015

I know, but i would like to know if someone could help in that particular topic. I created all the customizing for one step but i don't know if there is something to do in order to get de messages o where are the idocs sent.

In the monitor i get this messages

0 Kudos
1,015

Hello Diaz,

It looks like the configuration need to be checked from both the systems and make sure it has pointed to the right partners.

POSDM - Maintain the partner profile under KU with the specified message types with the correct port which connects to SAP Retail (ECC)

SAP Retail (ECC) - Maintain the partner profile for the same partner and the entries in Inbound parameters with the message type and process code

If you need more details, share the error screenshot from POSDM/ECC from WE02 or with control record with partner details to help you further.

0 Kudos
1,015

Hi Prakash, that's one of my problems. If you check the We02 in POSDM there is no idocs sent.

Let me explain to you that i created all the customizing using the one step processing, so, i supposed that when i create a document and process it it has to be able to send it to the partner that was created in the WE20 tcode.

Something that keeps me thinking is if i have to run something else in order to get the idoc created. The thing is that no getting error is not helping because i don't know where to start.

The other thing, that keeps me thinking is that the connection that sends documents to BW works, but the KU does not.

I have the following connections in POS DM:

a KU port connection, a LS (to SAP Retail), one LS to BW system (myself), the connection LS that receives the PI idocs.

If you want any screens you could share an email and i'll send it to you.

Thanks in advance

0 Kudos
1,015

SAP retail IDocs also should be in KU, no LS configuration is required in this step. Sender and receiver of this IDoc will be same but from the different systems.

Confirm if the task in the POSDM for the IDoc generation is successful, if not then we have to check the configuration of the IDoc task before spending more time of WE20 setup.

0 Kudos
1,015

Hi Prakash, indeed it is, the Idocs in the /posdw/mon0 give the green status. Later i'll give you a screenshot of this.

You told me that no LS has to be created, but if i have to send RSSEND RSINFO to BW for the Control transactions into BW, there is no need for this port?.

The other question, the WPUUMS and WPUTAB (aggregate ones) have to be created as one step? or the have to be created as 2 step processing?. I thought that if you choose a Step processing the other one no need to be fullfilled, is that right?

Thanks for your help

0 Kudos
1,015

Hi,

Are you sure IDoc is generated? Have you checked document flow tab in workbench.

Doing 1 step or 2 step is choice left to you.

You should use either one of them.

BW receives data from POSDM in delta queue which is again via tRFC. No IDoc is needed for that.

Thanks,

Vikrant.

Message was edited by: Vikrant Mohite

0 Kudos
1,015

Let me share you 2 screenshots about the document flow.

That are the only messages that i get from the system, As i told before, there is no idoc in the inbound of the SAP Retail System.

Thanks in advance

0 Kudos
1,015

Hi,

Can you just select one transaction where IDoc generation task is set to green and choose doc flos as in 2nd snap of yours.

Also when you are in doc flow click button pointing towards left (there are four icone up down left and right just above message text).

Thanks,

Vikrant.

0 Kudos
1,015

There you go Vikrant

0 Kudos
1,015

Hi Reynaldo,

Can you do one more time with highlighted button with single receipt.

After than expand the tree nodes and you should get outbound document.

Thanks,

Vikrant.

0 Kudos
1,015

Hi Vikrant, here is the screenshot you asked me for....

0 Kudos
1,015

Hi,

You are missing some configuration and therefore your task on transaction is not generating IDoc.

Please compare your config with standard config in system. You may able to trace what is missing.

Thanks,

Vikrant.

0 Kudos
1,015

Outbound tasks has to be configured in two step processing for the specified profile. Change the configuration accordingly and validate the task is getting triggered for the transaction to generate an IDoc.

0 Kudos
1,015

Hi Prakash, i'm getting in the tx /posdm/mon0 that the tasks are completed, do you know where do i look if the Idocs where created and sent to the receiver system?

Thanks

Reynaldo

0 Kudos
1,015

Look at WE02 transaction in both POSDM and SAP Retail (ECC) systems.

0 Kudos
1,015

Hi Prakash, In POS DM there is not Idocs (If you see the top of this Forum i spoke about it)

Those Idocs belong to BW, not to POS DM.

0 Kudos
1,015

Hi Reynaldo,

         If you cant see the WPUUMS idocs(i believe you are using aggregated sales idoc from POSDM to ECC), please check the below

1.Go to /POSDW/AGGR and find the Aggregate number for the store/posting date combination(with relevant min and max date)

2.Check the status of the aggregate number

If the status is "5" the aggregation is completed(which means you should be able to see the idoc in WE02 for the relevant store).

**It will be worthwhile checking the partner profile settings in WE20 wherein partner type KU should have the store number configured as customer with all the relevant message types(especially WPUUMS in your case) in POSDM outbound message section.Similar settings should have been done in ECC in the inbound message section.

If the Aggregate status is not "5" then you need to analyse depending on the status.You may have to either run the /posdw/odis to create an idoc if its not created at all.

Hope it helps.

Best Regards,

Aram.

0 Kudos
1,015

Hi Aram, thanks. I check all the data one by one I got the WPUUMS Idoc sent to SAP Retail. Now, i have some questions.

The first one, is that when i send the totals in the Balancing folder shows a Red Status. I activated the DataSource for Totals in Bw but the error still remains. (i will put the monitor to you)

The other question is that only WPUUMS doc is sent to SAP Retail, but WPUBON, WPUFIB and WPUTAB aren't. I'd like to know if the Idoc outbound processing has to have some kind of trigger in order to "activate" the Idoc sending to the Outbound server (in this example, SAP Retail)

Thanks in advance,

Reynaldo