SAP for Public Sector Discussions
Foster conversations about citizen engagement, resource optimization, and service delivery improvements in the public sector using SAP.
cancel
Showing results for 
Search instead for 
Did you mean: 

Field fill with Zero in FMDERIVE

former_member211458
Participant
0 Kudos
338

ello Gurus

A Help or suggestion. When I visualize a cost center this has 8 characters. when I compare its value to execute the derivation rule it shows me the value with 10 characters, filled with zeros to the left and can not find it, however if it is in the rule. ¿Any experience and solution with this problem?

1 ACCEPTED SOLUTION

iklovski
Active Contributor
0 Kudos
181

Hi,

Please, check the following OSS note if you have a release >= 6.04:

2097973 - FMDERIVE_ENH:Incorrect Rule Value Format For Saved Values

However, this note would be relevant only if you use enhanced FMDERIVE option.

Don't be alarmed by the fact that the value is presented with leading zeros in derivation log, though. The rule should be still working.

Post the screenshot of your rule. Make sure, that you have 'override' option switched on.

Regards,

Eli

View solution in original post

5 REPLIES 5

iklovski
Active Contributor
0 Kudos
182

Hi,

Please, check the following OSS note if you have a release >= 6.04:

2097973 - FMDERIVE_ENH:Incorrect Rule Value Format For Saved Values

However, this note would be relevant only if you use enhanced FMDERIVE option.

Don't be alarmed by the fact that the value is presented with leading zeros in derivation log, though. The rule should be still working.

Post the screenshot of your rule. Make sure, that you have 'override' option switched on.

Regards,

Eli

0 Kudos
181

Hi Eli

Very Thanks!!!

The version is 618 Enhanced (PSM_FM_CI_1) is active. I will verify the note and comment the result

Regards

Augusto Hector

Attach screen shot (number 4) of rule.

iklovski
Active Contributor
0 Kudos
181

I see in your rule that company code starts with '80' (it's truncated). However, in your FMDERIVE trace screen, company code is set to '1000'.

181

Its correct. I was wrong. Even with values with leading zeros the system compares them well

Very Thansk Eli

iklovski
Active Contributor
0 Kudos
181

You're welcome! 🙂