SAP for Higher Education and Research Discussions
Spark conversations about student engagement, research optimization, and administrative efficiency using SAP in higher education and research. Join in!
cancel
Showing results for 
Search instead for 
Did you mean: 

Starting parameter incomplete: student object ID not specified

Former Member
0 Kudos

Hi All,

I have an error while testing the Web-Dynpro application PIQ_STIC , it is giving me a unique message " starting parameter incomplete: Student object ID not specified " I have assigned the business partner key to the SAP User as specified in the course registration cookbook still the problem recurs.

Kindly suggest your valuable inputs to solve the issue.

Regards,

Sravan

13 REPLIES 13

Former Member
0 Kudos

HI

Can any one please update this ...am also facing the same issue...

Thanks

Kirankumar M

Former Member
0 Kudos

Hi Sravan:

I would suggest that you try the following:

Specify the Student Object ID (not the Business Partner number) in the Web Dynpro Transaction. Right click on the Transaction and choose "Change Favorite". Select the Parameter: STUDENT_OBJID from the drop-down list. Enter the Object ID in the field "Value", then re-start the Transaction.

Hope this helps,

Patricia

0 Kudos

Hi Patrica,

You are right. What actually i was expecting is when i log-in with a student User ID in the portal. The Object ID should get

populated in the Web Dynpro Paramer STUDENT_OBJID with value of the student User Id who is logged in.

Regards,

Sravan

0 Kudos

Can somebody give me an input on this?

0 Kudos

Sravan,

The Student Info Center is not meant to be a student self-service 'standalone' application. It was released as part of the Advisor User Interface, and is meant to be launched from the Advisor Worklist in the Enterprise Portal, where the Student Object ID is automatically passed.

Michael

0 Kudos

Hello Michael,

I was referring "PIQ_STIC" application to showcase my issue. I Could successfully launch this application in advisor worklist.

I had few other applications for which i am facing the same issue when i try to execute independently for the student role in portal.

I have linked the Business partner number of the student for the SAP User ID in R/3, and trying to log-on in portal. I am encouring the error " starting parameter incomplete: student object ID not specified "

Pl give your valuable inputs and correct me if i am going wrong

Thanks & Regards,

Sravan Kumar V

0 Kudos

Sravan,

For what student services are you having this issue?

Some things to check/consider:

- Are you using the delivered student role and the delivered Service Map?

- Are you using an RFC desitination to separate the Web Dynpro rendering from the back-end processing?

Michael

0 Kudos

Hello,

I've the same problem. Anyone got a solution there?

Regards,

Vermeer

0 Kudos

Hi Michael,

I now understand that we are trying to launch certain Web Dynpro applications independently though they are meant to be embedded into other web dynpros sothat the object ID gets populated by default. We are still working on this, will update you once i complete the activity.

Regards,

Sravan

0 Kudos

Hi Michael,

We are getting the same issue with all the servicesrelated to the student. Iam connecting backend and portal with RFC 's(JCO's)

SAP_HER and SAP_HER metadata.

Could you help me to resolve this issue on the priority basis.

Looking forward for your reply,

Shilpa.

0 Kudos

Hi Michael,

I can see the services related to student in portal. I am getting an error ' linked object not found' in the portal application. In the preview, only the following services are executed correctly.

1) course registration

2) Equivalancy determination

3)Grade change request

the following services are giving the error ' Starting parameter incomplete: student object ID not specified '

4) admission application

5) admission audit

6) change address

7) change of program

😎 change of specialization

the following services giving the errors " HRIQ_BAPI_BASIC_CHECK was called incorrectly" and " Object ST 00000000 doesn't exist"

9) Graduation

10) special booking authorization

11) Transcript

I can't understand where i am going wrong. I have linked the business partner with portal user id in the backend. RFC is maintained for student self-services in R/3

Looking forward for the solution.

Thanks and regards

Sravan

0 Kudos

Hi Michael,

I resolved the issue. I have specified a wrong RFC destination for student self-services. Now all the services are working fine when i test them in R/3.

Thank you for your time.

Regards,

Sravan

0 Kudos

Hello,

Can you explain please more in detail, what and where you have done the changes go get this apps work.

Regards

Vermeer