SAP for Higher Education and Research Discussions
Spark conversations about student engagement, research optimization, and administrative efficiency using SAP in higher education and research. Join in!
Showing results for 
Search instead for 
Did you mean: 

PDF not shown in browser

Former Member
0 Kudos


For our customer in the research industry we have the following problem:

When logging in to the add-on via the browser (Internet Explorer 11 or Chrome) we ask the add-on to show a salarystatement via PDF (we use Adobe Reader XI). There pops up a screen but the screen stays gray and dont show any information etc. I thought it can be solved to change something on settings in the browser or in Adobe , but it stays the same. It worked in the development environment, and didn't worked in the test environment, but now we have the same in both environments. After troubleshooting, we receive the following message:

  1. 1. Resource interpreted as Document but transferred with MIME type application/pdf:
    1. 1. UCF_PlaceHolder.createContentVM7004:1
    2. 2.  UCF_ControlFactory.oGetControlDomReflightspeed.js?4902693B908E:38
    3. 3.  UCF_ControlFactory.oCreateControlByIdlightspeed.js?4902693B908E:38
    4. 4.  UCF_ControlFactory.oGetControlByIdlightspeed.js?4902693B908E:38
    5. 5.  UCF_LS.processInitializeIDslightspeed.js?4902693B908E:44
    6. 6.  UCF_PageUpdater.processUpdateslightspeed.js?4902693B908E:28
    7. 7.  UCF_PageUpdater.onWindowOpenlightspeed.js?4902693B908E:28
    8. 8.  UCF_EventProvider.fireEventlightspeed.js?4902693B908E:10

Is anyone formiliar with this message or can someone help what it means? I hope you can help.


Jelle de Bruijn


Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Jelle; please (also) raise this question in the Netweaver group:

If there will no satisfying replies I suggest you create an OSS message on the correct component related to the product and/or NW stack.

Kind regards


Active Contributor
0 Kudos

Hello Jelle

It sounds like it's not SAP causing it.

Search for "Resource interpreted as Document but transferred with MIME type" + ADOBE!msg/chrome/L5ESeF1UWrg/fbuiEeIq9TcJ

You might want to look for things mentioned on those non SAP threads such as multiple Adobe versions causing issues etc.

Best regards


0 Kudos

I had a similar problema (just the part of "the screen staus Gray", maybe the other part too , but I don´t know where do you read this messages from).

The solution was to remove Adobe XI and substitute it by Adobe Reader X .

0 Kudos

I´m not sure abut previous posting, the problema appeared again .

I removed it again after I set the Adobe Reader checkbox:

Accesibility-->Show pdf documents in web explorer .