cancel
Showing results for 
Search instead for 
Did you mean: 

Login with Safari does not work anymore

stefan_koehler
Active Contributor
0 Kudos

Hi SCN team,

once again SCN is not working properly with Safari (Version 6.0.5 (7536.30.1)).

The browser keeps loading or is frozen, if i try to login on SCN (without certificate and "remember" password). I click on http://scn.sap.com/thread/login.jspa and then it is redirected to https://accounts.sap.com/saml2/idp/sso/accounts.sap.com?... and that's it.

Nothing more is happening. It works pretty well, if i try the same with Firefox 23.0.1 for example. Pretty annoying, that Safari seems not be tested at all by implementing changes or whatever.

Can you please fix this? Thank you.

Regards

Stefan

Accepted Solutions (0)

Answers (7)

Answers (7)

0 Kudos

@Stefan Koehler

I found this solution, have a look maybe this works.

Re: SCN Login problem on Safari MacOS

0 Kudos

Hello Everyone,

Due to security reasons, we cannot support MAC Safari on MAC OS 10.7.  MAC Safari, unlike Firefox or Chrome, uses the SSL libraries provided by the operating system.  There are know security issues with this version of the SSL libraries.

MAC Safari is supported on versions 10.8 and above.  For those users who must remain on MAC OS 10.7, only FireFox and Google Chrome are supported.

Thanks,

Charles Carney

SAP ID Service Product Owner

Former Member
0 Kudos

Thank you, Charles, for clarifying and closing this thread.  I'm using Firefox for SCN and it works fine. I'll upgrade my Safari once my company's comfortable with the latest new Apple OS.

manfred_stein
Employee
Employee
0 Kudos

Hi Charles

Said security issue has been adressed by Apple in the meantime (Lion being still under full Apple support) . I still run into the issue regularly and switching to Firefox is not what I understand under user friendly. I believe we should do better with this. Worst case I might simple be too lazy in helping solve problems reported by our community:-(

Manfred

Former Member
0 Kudos

Hi Charles,

Once again there are issues with the log in from Safari.

I use Safari 7.0.6 on OSX Mavericks and just renewed the certificate, but no luck in getting on to the market place.  As stated before by other users, the browser just freezes and keeps on asking for the certificate.

Can you please solve these issues?

Jorn

0 Kudos

Hi Jorn,

Thank your for your feedback but if you are attempting to authenticate against service.sap.com, SAP ID service does not provide the authentication or identity management.  Please open a ticket on the Service Marketplace for the issue.

Kind regards,

Charles

0 Kudos

Hi Stefan,

I am the Product Owner for SAP ID service.  We provide the log on and registration for SCN.

We are looking into the issue.  Our current findings indicate a certificate issue with the last two versions of Safari.  Do you have an SAP Service Marketplace certificate also installed in your Keychain?

Thanks,

Charles Carney

SAP ID Service Product Owner

stefan_koehler
Active Contributor
0 Kudos

Hi Charles,

no i have no SMP certificated installed as previously mentioned "The browser keeps loading or is frozen, if i try to login on SCN (without certificate and "remember" password).". I am using the "normal" user and password login, but this does not work anymore too.

I am using user id and password logon due to this issue here since i am on Mac OS X and Safari.

Regards

Stefan

stefan_koehler
Active Contributor
0 Kudos

Hi,

performed an update of Safari to version 6.1 (7537.71), but issue also still there.

Is somebody working on this issue at all? I can not find a corresponding bug note in this document (http://scn.sap.com/docs/DOC-24192) here. Reported this issue over a month ago

Regards

Stefan

stefan_koehler
Active Contributor
0 Kudos

... still there after applying patches on Sunday

JasonLax
Product and Topic Expert
Product and Topic Expert
0 Kudos

Meh. Thanks for the feedback. 

Cc: Former Member

Former Member
0 Kudos

I'll confirm: yep, me too. Safari login has a certificate problem; Firefox works in the meantime. I am convinced this occurred due to the Apple OS update since the timing coincided... the new OS introduces something that didn't exist before.

stefan_koehler
Active Contributor
0 Kudos

Hi Mark,

glad to hear, that i am not the only one, but unfortunately it seems not to care anybody at all.

Issue is still there (even after applying fixes on 6th October once again) and i can not even see a bug note for that issue.

Regards

Stefan

P.S.: I have not updated Mac OS in the meantime and it seems like other users have the same issue on Windows too (http://scn.sap.com/thread/3433615)

georg_schukat
Explorer
0 Kudos

Still the same issue here with Safari 6.0.5 on OSX 10.7.5!

Firefox okay.

After removing all SAP cookies it behaves different than when there are some left.

But login in neither nor possible.

Please resolve this issue asap!

stefan_koehler
Active Contributor
0 Kudos

Hi SCN team,

does anybody take notice of this issue? It is still there ...

In addition here is the HTTP stream until it freezes - maybe it helps (i have just replaced the sensitive information with <XXXX>).

GET /community/oracle/login.jspa HTTP/1.1

Host: scn.sap.com

User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/536.30.1 (KHTML, like Gecko) Version/6.0.5 Safari/536.30.1

Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8

Referer: http://scn.sap.com/community/oracle/content

Accept-Language: de-de

Accept-Encoding: gzip, deflate

Cookie: jive.server.info="serverName=scn.sap.com:serverPort=80:contextPath=:localName=localhost.localdomain:localPort=9001:localAddr=127.0.0.1"; JSESSIONID=<XXXX>.; scn_sbs_prod_cookie=<XXXX>; anonymous=false; shpuvid=172.16.92.4.1379334424701018; s_pers=%20s_ttc%3D1379334443%7C1410870442684%3B%20s_nr%3D1379667811029-Returning%7C1382259811029%3B%20s_fid%3D2753083733048E06-39B713401260C383%7C1442739820782%3B%20gpv_p9%3DlogN%7C1379669620785%3B%20c13%3Dscn-jive%253Aglo%253Awiki%7C1379669620789%3B%20pe%3Dno%2520value%7C1379669620792%3B%20c3%3Dnon-blog%2520page%2520view%7C1379669620794%3B%20s_sapvisid%3D56514d5a1ecb11e391e935d20137e8bd%7C1509271420798%3B%20s_visit%3D1%7C1379669620799%3B; s_sess=%20s_cc%3Dtrue%3B%20v18%3D1%3B%20s_sq%3Dsapcommunity%252Csapglobal%253D%252526pid%25253Dscn-jive%2525253Aglo%2525253Awiki%252526pidt%25253D1%252526oid%25253Dhttp%2525253A%2525252F%2525252Fscn.sap.com%2525252Fcommunity%2525252Foracle%2525252Flogin.jspa%252526ot%25253DA%3B; mbox=session#1379667608633-823196#1379669671|check#true#1379667871; session=8556ef56-21d3-11e3-b181-bbc621486082; shpuvid=rBBcnFI7HZxFXh13A3JwAg==; client=56514d5a-1ecb-11e3-91e9-35d20137e8bd; SAP.TTC=1379334443; __gads=ID=be69a658b50dfb84:T=1379334441:S=ALNI_MY9dn-KS89rl6-h86DdjWaxt2yj0g

Connection: keep-alive

HTTP/1.1 302 Moved Temporarily

Date: Fri, 20 Sep 2013 09:03:40 GMT

Server: Apache-Coyote/1.1

SDN_UID: Anonymous

Pragma: no-cache

X-JAL: 16

Location: https://accounts.sap.com/saml2/idp/sso/accounts.sap.com?SAMLRequest=<XXXX>

Expires: Fri, 20 Sep 2013 09:03:40 GMT

Vary: Accept-Encoding,User-Agent

Content-Encoding: gzip

Cache-control: no-cache, no-store, no-store, no-cache, must-revalidate, private, max-age=0

X-JSL: D=18137 t=1379667820814147

Content-Length: 20

Keep-Alive: timeout=5, max=95

Connection: Keep-Alive

Content-Type: text/plain

....................

Thank you.

Regards

Stefan

amine_lamkaissi
Active Contributor
0 Kudos

Hi Stefan,

Are you on a mac or a windows system?

Amine

stefan_koehler
Active Contributor
0 Kudos

Hi Amine,

i am using Mac (10.7.5 Build 11G63). It even does no auto login with Safari, but with Firefox this works as well.

I also tried to find out any HTTP error code with Safari, but the login is just redirected and that's it .. no error .. nothing ...

Regards

Stefan

P.S.: It worked pretty well with Safari too until  last week.