Showing results for 
Search instead for 
Did you mean: 

Active Database failed

Former Member
0 Kudos

Hi All,

When i'm trying to start sap using startsap command getting the following error.

Checking db6 db Database


ABAP Database is not available via R3trans

Starting SAP-Collector Daemon


15:05:08 27.02.2013   LOG: Effective User Id is root


* This is Saposcol Version COLL 20.95 700 - V2.7.1 2008-08-11 HP-UX IA64

* Usage:  saposcol -l: Start OS Collector

*         saposcol -k: Stop  OS Collector

*         saposcol -d: OS Collector Dialog Mode

*         saposcol -s: OS Collector Status

* The OS Collector (PID 3460) is already running .....


saposcol already running

Running /usr/sap/DEV/SYS/exe/run/startdb

SQL1042C  An unexpected system error occurred.  SQLSTATE=58004

Activate database failed

R3trans connect failed

DB startup failed

shivdev:devadm 22>



Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Try to start the database first:

change user to db2<sid> and type


then change user to <SID>adm and type


Former Member
0 Kudos

I have tried this but still facing the same error.