cancel
Showing results for 
Search instead for 
Did you mean: 

SAP Digital Manufacturing for insights OData Service Functionalities does not work

schfer_christian
Explorer
0 Kudos

Hi Together, I want to use

SAP Digital Manufacturing for insights OData Service Functionalities

What do I have?

1) I use Postman

2) I have the service URL created like described here:

https://help.sap.com/docs/sap-digital-manufacturing/insights/apis

3) I have Token by using [System]/oauth/token

What do I want to do:

1) I want to access [public-api-endpoint]/dmci/v1/extractor/Plant('1000')/Material?$format=json&$select=Plant,Material,MaterialVersion&$filter=Plant eq '1000' and Type eq 'SEMIFINISHED_PRODUCT'

but here I always get 404 not found.

I tried to use

https://help.sap.com/docs/sap-digital-manufacturing/operations-guide/prepare-for-api-integration

and do the creation of Service Instance because maybe the endpoint I use is wrong:

  1. Go to your subaccount.

  2. Choose Services Service Marketplace and then select the Digital Manufacturing Cloud Services tile for the production plan.

  3. Choose a service plan to create an instance of the service.

  4. Choose Create.

  5. Create an instance:

  1. Select the service plan based on your license:
  • insights (for consumption of SAP Digital Manufacturing for insights APIs)

But in step 5 I have no service plan "insights" available

Maybe someone here knows the problem and can help?

Accepted Solutions (1)

Accepted Solutions (1)

Kevin_Hunter
Employee
Employee

Hi Christian,

I just test this on my side and it worked without issue using this URL https://api.test.eu20.dmc.cloud.sap/dmci/v1/extractor/Plant('KEVH')/Material?$format=json&$select=Plant,Material,MaterialVersion&$filter=Plant eq 'KEVH' and Type eq 'SEMIFINISHED_PRODUCT'

404 suggests the issue is with the URL so can you share the URL you used ?

Thanks

Kevin

Answers (1)

Answers (1)

schfer_christian
Explorer
0 Kudos

Hi Kevin thx for your answer.

I think it works now.

I used the wrong adress I think.

https://api.eu20.dmc.cloud.sap/dmci/v1/extractor/$metadata

--> thats my one

Yours works for me, so I tried to figure out why 🙂

From

https://help.sap.com/docs/sap-digital-manufacturing/insights/apis

I read again and I found:

"in the above examples, https://api.eu20.dmc.cloud.sap is the base URL indicating the production tenant in EU20 landscape.

To access the SAP Digital Manufacturing for insights public APIs, you must use the public-api-endpoint from the service key."

This information is important in the help document, so I checked this and have seen I need to use the URL like you have.

https://api.test.eu20.dmc.cloud.sap/dmci/v1/extractor/Plant('1000')/Material?$format=json&$select=Plant,Material,MaterialVersion&$filter=Plant eq '1000' and Type eq 'SEMIFINISHED_PRODUCT'

Thx again for the fast answer 🙂