cancel
Showing results for 
Search instead for 
Did you mean: 

Question about /TDAG/CPM00

rudy_schmitz
Active Participant
0 Kudos
246

Hello,

I have the following question about transaction /TDAG/CPM00:

When I do a search (on the first screen), specifying the material number as identifier criteria, I receive a list of the substances that correspond to this material number & suppliers.

But, when I do a search (on the first screen), specifying the material number in the corresponding field, I get, on the 2nd screen, the real substance.

If I double-click on this real_sub, I get the list of combinations of material number & suppliers.

But in this list, some are missing if I compare to the first list.

I already tried to findout the reason for this (valid from/to date, deletion flag, ...), but I can't find the reason.

I also looked in tables ESTRH, ESTRI, ESTMJ, without success.

Is it possible that it is just a limitation???

Or can somebody explain me why these 2 lists are not the same?

Thanks in advance for your light on this subject.

Regards,

Rudy

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member209335
Contributor
0 Kudos

Hi Ruby,

When you execute the transactions code /TDAG/CPM00 for searching materials ,getting  "timeouts occur" error.

The Reason behind this.

The wrong secondary index is determined or used during the SQL access  (SELECT) to the table AUSP....

Refer this Note you get some corrections Instructions for solve  this issue  :Note 1471769 and https://websmp230.sap-ag.de/sap%28bD1lbiZjPTAwMQ==%29/bc/bsp/spn/corr_instr/correction_instructions....

Edward

rudy_schmitz
Active Participant
0 Kudos

Hello Edward,

Thank you for your reply, but I don't receive any timeout.

Maybe another clue:

I was doing some tests for a system update (don't ask me which version, I have no idea).

During these tests, I created a new substance with BOMBOS transfer.

Then, I noticed a problem due to a missing function module. Our system maintenance team solved this problem by installing "Service Pack 04".

After the installation of this SP04, I restarted my tests.

I created 2 new substances (for same material as before) with BOMBOS transfer.

Then, in /TDAG/CMP00, selecting the material number, I could see the 1st substance I created before SP04, but not the 2 new ones.

But searching with the material number as identifier criteria, I can see the 3 substances I tried to create.

Does anyone have an idea?

Thanks in advance for your lights...

Rudy