cancel
Showing results for 
Search instead for 
Did you mean: 

Production Order not getting saved in SAP MII OEE

Hi,

We are getting error while transferring Production Order idoc from SAP ERP to SAP MII OEE tables using IDOC.

We have followed SAP OEE Help document. As per it, we have completed ALE settings. Ran SAP OEE NetWeaver Configuration CTC and Integration Config CTC wizards.

Transferred following items from SAP ERP to SAP MII OEE tables via IDOC.

1. Plant Hierarchy

2. Reason Codes

3. Data Collection Element, Data Elements, Data Element Type

4. Material Master (Header and Components)

5. Workcenter

6. Shift

7. Production Mode

8. Production Activity

Also I have checked below points also:-

A. Workflow Configuration is available for production order.

B. Production Order IDOC is of type LOIPRO01

C. Production Order is in released status.

D. All the components and Material required in Production Order \ Process Order are sent from ERP

E. Plant Hierarchy is sent from ERP and can be seen in Worker UI "Display ERP Data".

F. Work center associated with Order and Plant Hierarchy Sent from ERP using LOIWCS03.

G. Production Order is not confirmed to ERP

H. Plant Hierarchy have work center associated with the production order.

But still getting Error Message while transferring Production Order.

============================

. Error: ' [STEP = STD_SERVICE]. Production order could not be saved'

============================

Kindly provide your valuable inputs if anyone has faced such issue.

Your response will be much appreciated.

Best Regards,

Anshul Arora

Are the Materials in the Production Order associated with the correct Plant? Just a guess on my part, but I have run into that sort of problem in the past.

Have you checked SM59 to see if the IDoc was properly generated before being transferred to MII/OEE?

Also please check the configuration document for OEE to make sure you should be using LOIPRO01. If memory serves correctly (and it might not), I think it should be LOIPRO03.

Regards, Mike

As long as it worked, right? There is a lot of commonality between the versions of LOIPRO, so perhaps it does not matter which one is used.

Congratulations on solving it. I recommend changing your comment to an Answer and then marking it as the correct Answer for those who might run into similar kinds of issues.

Cheers, Mike

0 Kudos

Sure.

Thanks Mike.

Accepted Solutions (0)

Answers (1)

Answers (1)

0 Kudos

Hi Mike,

Thank you for your response.

I solved the issue by looking at log viewer. I found out an error due to missing Line Behavior Configuration in Worker UI -> General Configuration (SAP MII Navigation). Where on the Line Node, there is a customization configuration named as "Line Behavior * ". It is a mandatory field that was not having any value.

I selected one value for it out of the values mentioned in its drop down values. After saving it, I retried the LOIPRO01 idoc from Queue Monitor. And it got passed.

I believe for SAP OEE MII Workflows, we have only one type of LOIPRO Message Type defined i.e LOIPRO01. And we have SAP MII 15.3 version.

Best Regards,

Anshul Arora