cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to generate custom template

AnnaGiorgia_Aj
Explorer
0 Kudos

I have have created a custom template (a custom documentation style) to generate word documents using Producer. Then I added the style ad a template for the hands on guide.

When I try to use it to generate a new document from a Simulation, though, the Producer creashes and displays the following error: "the object invoked was disconnected from its clients".

We must user dotx templates as for policy.

Surely, Issue has nothing to do with our template customization because it worked for another customer.

Do you have any suggestions?

Thank you in advance for your help.

Accepted Solutions (0)

Answers (1)

Answers (1)

DirkManuel
Active Contributor
0 Kudos

The documents can be a bit tricky. My suggestion would be to delete the one you have created, because it is corrupted, and figuring out why will take longer than it will take to just recreate it. SAP Enable Now does support .dotx templates, so that shouldn't be the problem.

I would suggest you first take an existing (SAP-provided) Document Template (.dot) and save it outside of SAP Enable Now. Save it as a .dotx file, and then load it back into SAP Enable Now as a new Document Template, unchanged. Generate a document with that (existing Document Type, but using your new template), and it should work if you have changed nothing else. Then start customizing the template (outside of SAP Enable Now, and re-loading it into SAP Enable Now. Make small changes and test between each iteration. That's usually a better way of working as if/when something goes wrong, you can go back to the prior version that did work.

AnnaGiorgia_Aj
Explorer
0 Kudos

Thank you Manuel. Let's try it! 🙂

AnnaGiorgia_Aj
Explorer
0 Kudos

We are able to save it a a .dotx file, and then load it back into SAP Enable Now as a new Document Template, unchanged. When we Generate a document with that unchanged template it does not work.

Do you have any other idea?

AnnaGiorgia_Aj
Explorer
0 Kudos

Moreover, I think that it's really odd because the same procedure/the same custom template works in another SEN environment in which we tested it.

DirkManuel
Active Contributor
0 Kudos

Try deselecting the option under Tools > Settings > Producer > General > Forbid Active Content, and see if that makes a difference.

AnnaGiorgia_Aj
Explorer
0 Kudos

Hi Manuel, I tried to edit the .dot file and import it as an archive. It seems that it's now working but the custom document (SAP - Single document with title) is showing only for me. If my colleague try to export word (custom) document the standard one is showing. The same if she click under Doc Style (the custom one) - SAP Single document with Title.

Moreover, disabling the "forbid active content" settings did not make any difference.

Any suggestions?

DirkManuel
Active Contributor
0 Kudos

I'm not sure why you imported it as an archive - you should have just inserted it as a file asset of the existing Documentation Style group (or any other Group - it doesn't actually matter). But if your colleague is not seeing it, that implies that it (or the Group you included it in) has not been saved to the server. Often when you import a file it only stores it locally, and you have to explicitly save it to the server.