cancel
Showing results for 
Search instead for 
Did you mean: 

SCORM package issue with XML Namespace

CedricL
Discoverer
0 Kudos
1,236

Hi,

We have SCORM packages with this kind of XML in the imsmanifest.xml file below. It's validated succesfully against SCORM Cloud and follows the specification ADL made, but fails when importing into SF Learning with the following error "The Content Package definition is required in the manifest file".

If we remove the section <imsmd:lom></imsmd:lom>, then it works.

Is that a bug from SF Learning, not parsing correctly XML namespaces?

Thanks.

<?xml version="1.0" encoding="UTF-8"?>
<manifest identifier="DF12955C-58C8-4337-34C2-21152C41940F"
	  xmlns="http://www.imsproject.org/xsd/imscp_rootv1p1p2"
	  xmlns:imsmd="http://www.imsglobal.org/xsd/imsmd_rootv1p2p1"
	  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
	  xmlns:adlcp="http://www.adlnet.org/xsd/adlcp_rootv1p2" 
	  xsi:schemaLocation="http://www.imsproject.org/xsd/imscp_rootv1p1p2 imscp_rootv1p1p2.xsd http://www.imsglobal.org/xsd/imsmd_rootv1p2p1 imsmd_rootv1p2p1.xsd http://www.adlnet.org/xsd/adlcp_rootv1p2 adlcp_rootv1p2.xsd">
  <metadata>
    <schema>ADL SCORM</schema>
    <schemaversion>1.2</schemaversion>
    <imsmd:lom>
      <imsmd:general>
        <imsmd:title>
          <imsmd:langstring xml:lang="en">Test Package</imsmd:langstring>
        </imsmd:title>
        <imsmd:language>en-GB</imsmd:language>
        <imsmd:description>
          <imsmd:langstring xml:lang="en"></imsmd:langstring>
        </imsmd:description>
      </imsmd:general>
      <imsmd:lifecycle>
        <imsmd:contribute>
          <imsmd:role>
            <imsmd:source>
              <imsmd:langstring xml:lang="en">LOMv1.0</imsmd:langstring>
            </imsmd:source>
            <imsmd:value>
              <imsmd:langstring xml:lang="en">Author</imsmd:langstring>
            </imsmd:value>
          </imsmd:role>
            <imsmd:centity>
              <imsmd:vcard>begin:vcard fn:  end:vcard</imsmd:vcard>
            </imsmd:centity>
          <imsmd:date>
            <imsmd:datetime>19-12-19</imsmd:datetime>
          </imsmd:date>
        </imsmd:contribute>
      </imsmd:lifecycle>
      <imsmd:technical>
        <imsmd:duration>
          <imsmd:datetime>00:46:00</imsmd:datetime>
        </imsmd:duration>
      </imsmd:technical>
    </imsmd:lom>
  </metadata>
  <organizations default="ORG-9CE7B0771366E1E813F3BE249E089644">
    <organization identifier="ORG-9CE7B0771366E1E813F3BE249E089644" structure="hierarchical">
      <title>My Test Package</title>
      <item identifier="ITEM-E159F3DAD58B6E0BACC6073680B75BC8" identifierref="RES-F2A7E76AF219E1172B96917119445F5C" isvisible="true">
        <title>My Test Package</title>
      </item>
    </organization>
  </organizations>
  <resources>
    ...
  </resources>
</manifest>

Accepted Solutions (0)

Answers (1)

Answers (1)

0 Kudos

Hello Mr. Lebrun,

I'm glad to find somone with an identic Issue like us.

In our case, the issue was solved, when we define the metadata new.

Good luck!