Showing results for 
Search instead for 
Did you mean: 

RFC error when using BICA in Production

Former Member
0 Kudos


After final transport to Prod, we are unable to import schema from queries with dimensions in Prod. Queries without dimensions are OK.

After investigations, we noticed that we have a RFC error :

TRACE BWP dev_rfc.trc

        • Trace file opened at 20110222 142806 CET SAP-REL 700,0,245 RFC-VER nU 3 1139952

======> CPIC-CALL: 'ThSAPCMRCV' : cmRc=20 thRc=223

ABAP Programm: SAPMSSY1 (Transaction: )

Called function module: BAPI_MDPROVIDER_GET_LEVELS

User: BWPADM (Client: 101)

Destination: psbwpvip1_BWP_30 (handle: 1, 05465956, )

SERVER> RFC Server Session (handle: 1, 05465956, )

SERVER> Caller host:

SERVER> Caller transaction code: (Caller Program: lss)


Error RFCIO_ERROR_SYSERROR in abrfcpic.c : 3349

CPIC-CALL: 'ThSAPCMRCV' : cmRc=20 thRc=223

We tried to reroute our Prod server to BW Quality in file LSDAL.ini and it is working. It seems that we have a communication problem with our BW Prod.

Have you idea of what I should check to solve it ?



Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Matt,

In the Application Server/Home directory there is a trace file that is created when importing schema or data.

The file is called BICTRACE_SCHEMA_<MODELNAME> for importing schema and BICTRACE_DATA_<MODELNAME> for importing data.

That trace file may have a better error message in it to tell you what may be going wrong. open it in notepad and see if there is a better error. this is the log we use to troubleshoot BICA problems.

When you rerouted the server and the import worked , did you change anything such as the LINKID?

If you did not and the import worked then we can assume the application is working OK, as you say there may be a communication problem.



Former Member
0 Kudos

Hi Bill,

In the trace I found :



and that's it. It seems that the communication is interrupted at this point. In the RFC trace, there is a MF BAPI_MDPROVIDER_GET_LEVELS in cause.

I suspect a problem with the infoobject 0PROFIT_CTR.

In quality everything is working well. We have the same hierarchy in production. The only difference is that we have twice as much hierarchy in prod than in dev.

So I wonder if this Module function called by SSM count all the levels of all hierarchy and override the max level authorized (256 by dim) ?

Of course in our query we have 1 hierarchy used (in graphic representation).

Thanks for your input


Former Member
0 Kudos

Hi Matt,

If you think you may be hitting a PAS maximum for # of hierarchies, you could enable PAS trace and reproduce the import and see if the trace file reports a problem with maximums.

In 7.5 you can enable this from the Administration section -> Set Application Defaults (system defaults?)

This will then automatically create files like:

a. DEFAULTGUEST436816399_both.txt

b. DEFAULTGUEST436816399_cmd.txt

c. DEFAULTGUEST436816399_time.txt

in your u2018/Homeu2019 directory (u2018...Files\SAP\SSM\ApplicationServer\homeu2019).

In this instance DEFAULT is the context name, GUEST the PAS username for the context, and the number a numeric sequence generated for uniqueness. You may need to shutdown the SSM Extended Listener service in order to look at the trace files.

The _both.text file has the best info.

Can you restrict the dimension in the query before you import it to see if it loads?



Former Member
0 Kudos

HI bill

I will have a look to those files today. Anyway we are currently in contact with SAP. I will let you know when updated.