Showing results for 
Search instead for 
Did you mean: 

Hierarchy node selections - wrong message that several hierarchies are used

Active Contributor
0 Kudos

Hi all,

I am creating a query in eclipse photon.

I want to use:

  • Hierarchy node selection in filter
  • Hirarchy node or leaf selection in default values (of course a more detailed node below the one I choose in filter)
  • show the characteristc values as flat list in query drilldown.

My characteristic is 0COSTELMNT

when I build my query like this, I get a warning message in the query, that I would be using different hierarchies - which I don´s. I have choosen always the same hierarchy.

When I choose hierarchy display for my char, I still get the message.

As a reporting query it would probably not be a problem, but as a plan query it is not entry enabled.

What can I do?

thanks and best regards


Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

Hi Gregor,

I enclose a screenshot of the system version info, but basically it´s a 7.5 SP12.

In RSRT I get the same messages as in eclipse, regenerating does also not help.

My data model is ADSO -> Composite -> Aggr Level -> Query.

I get 2 times the same message BRAIN087

If I take out the hierarchy selection on the info object display properties, I get only one message. or if I mark "activate hierarchy".

This is a screenshot of my query selections:

When I execute the query, I get this error message:

Ungültige Auswahl für Merkmal 0COSTELMNT Kostenart (RSBOLAP-008, BE1)

and the system does not use my default filter, but it is showing all cost elements which are included into the hierarchy node, that I included in the filter.

My target is to have one query where users can see all cost elements from a top node aand plan onthose, and have a second query for a fast "copy/paste" of values, where the query is pre-selected on inly one cost element, but it shall be changeable and therfore I want to have one cost element in default values.

And in This query I do not use disaggregation.

But he, while explaining it I tried lo´t of funny combinations of settings and found one, that works:

Use Hierarchy node selelction in filter

use flat list selection in default

no hierarchy display in query drilldown

this is what the query looks like now:

I still wonder, why the selection in default for hierarchy node does not work, even when I activate the hierarchy display in the query.

But this last way whith flat list selection and flat list display is fine for my purpose.

Thanks and best regards




0 Kudos

Hi Cornelia,

I stumbled on this thread while looking for same problem "Different hierarchies are used for characteristic xy - BRAIN 087".

Clearing and deactivating the hierarchy for the characteristics work for me also. Since I'm using non-BICS frontend, I can choose a hierarchy to show on frontend without having to activate the hierarchy during query design.

Just wanna leave a big thank you 😄

Best regards,


Answers (1)

Answers (1)

0 Kudos

Hi Cornelia,

this seems to be a bug; what is the release, support package you are using and what is the message you get (message class, number). You should get the same message if you re-generate the query. I also don't why this should have an impact on input-ready queries: maybe the query-view is aggregated with respect to the aggregation level and disaggregation is not used.