cancel
Showing results for 
Search instead for 
Did you mean: 

Syntax error in program "CL_PSM_CORE_SWITCH_CHECK======CP "

Former Member
0 Kudos

Hi Gurus

We have just completed EHP4 installation , we are getting a runtime error in the general ledger. There are many transactions that are giving us this same error. I tried to run the program RGZZGLUX as suggested in note 377053 and 1365712 but its coming to the same error. The error is also coming if any of the following transactions is accessed:

1) Defining the Leading ledger

2) Front end processes with integration to G/L accounting u2013 all modules

3) Defining Chart of Depreciation and Deprecation areas

4) Activating cost centres/profit centres/internal orders

5) Defining Field Selection for the Equipment Master Record( common fields) u2013 transaction OIAF

Below is part of one of the run time errors that is coming:

Moderator message - Please respect the 2,500 character maximum when posting. Post only the relevant portions of code

Edited by: Rob Burbank on Jun 2, 2010 2:03 PM

Accepted Solutions (0)

Answers (1)

Answers (1)

former_member589029
Active Contributor
0 Kudos

There is a note from SAP: 1237267

Symptom

Terminations may occur in applications that use the central field selection.

Other terms

CAC2, OIAD

Reason and Prerequisites

The customer has a system landscape that is based on an ABA layer

SAP_ABA 701, SAP_ABA 702 or SAP_ABA 711 and the application on a release lower than Enhancement Package 4.

The switch class CL_PSM_CORE_SWITCH_CHECK is available in such a constellation but the method PSM_FM_CORE_BUD_PER_REV_1 is not available.

This constellation is not caught and leads to the runtime error.

Solution

Implement the corrections.

This suggests that this problem only happens below EHP4. Did you encounter any problems during upgrade so that this class is not as it is supposed to be?

Since this is standard you might want to raise an OSS to SAP in regard to this.

Hope that helps,

Michael

Former Member
0 Kudos

Hi Michael

Thanks for the reponse

I didnt face any problems during upgrade. I have already raised an OSS with SAP but they have not responded yet.

regards

Partson