cancel
Showing results for 
Search instead for 
Did you mean: 

SWPM + S/4 Hana-Foundation 2021 Installation Error due WPxx died. db_connect error.

christoph_ostrop
Active Contributor
0 Kudos

try to install S/4H-Foundation 2021 system (with SWPM 2.0 SP14)

on RHEL-8.6. with Hana-2.0_SP06, error SWPM hanging - System did not start correctly,

disp+work WPnn did not come up, WPnn died, DB-Connect failed:

SWPM-error

An error occurred while processing option SAP S/4HANA Foundation 2021 > SAP HANA Database > Installation > Application Server ABAP > Standard System > Standard System (Last error reported by the step: Instance XYZ/D00 reached state STOP after having state STARTING. Giving up). You can now:

  • Choose Retry
    to repeat the current step.
  • Choose Log Files
    to get more information about the error.
  • Stop the option and continue later.

===

dev_wnn (logfile)

M Fri Mar 17 16:35:03:799 2023

M ThInit: running on host xxxxxx

I MtxInit: ABAP_WP_3 0 0

M ThMtxInit: activate stack on Mtx lockwait

M ThDbConnect: calling db_connect ...

B Loading DB library '/usr/sap/XYZ/D00/exe/dbhdbslib.so' ...

B Library '/usr/sap/XYZ/D00/exe/dbhdbslib.so' loaded

B Version of '/usr/sap/XYZ/D00/exe/dbhdbslib.so' is "785.03", patchlevel (0.200)

C Callback functions for dynamic profile parameter registered

C

C Load library /usr/sap/XYZ/D00/exe/dbhdbsqldbcversion.so

M *** ERROR => DlLoadLib()==DLENOACCESS - dlopen("/usr/sap/XYZ/D00/exe/dbhdbsqldbcversion.so") FAILED

"libSQLDBCHDB.so: cannot open shared object file: No such file or directory" [dlux.c 550]

C *** ERROR => Couldn't load library '/usr/sap/XYZ/D00/exe/dbhdbsqldbcversion.so'

[dbsdbutl.cpp 1301]

M ***LOG R19=> ThDbConnect, db_connect () [thxxtool.c 6068]

M ThIErrHandle: in_ThErrHandle: 1

M *** ERROR => ThInit: db_connect (step TH_INIT, thRc ERROR-DB-CONNECT_ERROR, action STOP_WP, level 1) [thxxhead.c 2833]

===

how to go on ?

Accepted Solutions (1)

Accepted Solutions (1)

Billelinfo27
Participant
christoph_ostrop
Active Contributor
0 Kudos

Hi, thanks for your answer,

HanaDB + new Appl.Server are running on the same server, so there is no remote DB.

yes, the /home/xyzadm directory content has already xyzadm:sapsys owner user/group

within /home/xyzadm it tried to change to => chmod g+r .*

but that also did not help,

also the HDBclient directory ( /usr/sap/XYZ/hdbclient ) is already xyzadm:sapsys owner user/group

regards

Christoph

christoph_ostrop
Active Contributor
0 Kudos

sorry, first i did not see the second comment in this thread,

https://www.itsfullofstars.de/2021/04/sap-netweaver-abap-not-starting-libsqldbchdb-so-missing/

the hint is: <sid>adm did not have csh

after install csh => yum install tcsh

and maintain /etc/passwd to that <sid>adm to /bin/csh

=> retry in SWPM installation

and YES, that solved the issue !!!

thank you very much 🙂

======

but i wonder why SAP in SWPM did not set-up this option, and did not check that ???

Christoph

Answers (1)

Answers (1)

Billelinfo27
Participant

Hi Christoph,

I'm just happy to know that the solution worked for you 🙂

For the the why, I think the answer is at the point 5.5 Prerequisites for Running Software Provisioning Manager in the installation guide for SWPM 2.0SP14.

Regards

Billel

christoph_ostrop
Active Contributor
0 Kudos

yes, you are right, 🙂

somewhere in the very extensive SAP info pool it is definitely written what has to be done,

but the SWPM checks many things, some less important, some much more important,

but these basic requirements are apparently not checked, but whether a password is checked is at least 12 or at least 14 characters long,

perhaps the PreRequirements should be checked first.

===

and during SWPM run, there is an option, if <sid>adm already exists, what to do:

option reset os-user was marked and i would assume, that SWPM will setup all needed options e.g. csh shell.

but obviously SWPM did not.

thanks,

Christoph