cancel
Showing results for 
Search instead for 
Did you mean: 

Leave Approval personalizing is not working

former_member283648
Participant
0 Kudos

Hi,

I am trying to hide time accounts from Leave Approval screen by using personalization. When preview the iView in portal content it is working fine. But this is not working when I access leave approval screen by clicking the leave request from UWL.

Same thing I did for Leave request, it is working fine.

Any clue to solve this issue.

Regards,

Bala

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

hey hi ,

I am giving you example how dose personalization work ..............take the idea and do it .

Let say, you would like to do personalization for Edit Exchange rate.

Please make sure that you do personalization at role level.

Logon with super admin role.

Content admin-> portal content->... ->employee self service > roles->xx ess role->open.

Open Edit Exchange rate I_VIEW and then preview it.

Select the field you would like to personalize.

Now Press control + right click.

Set as invisible Yes and set it as final.

Apply and ok.

Now for all ess users assigned with role "xx ess role" your personalization will work.

former_member283648
Participant
0 Kudos

Hi,

Thanks for the reply.

I have done the same steps. But it is working for Leave request screen. But it is not working for Leave approval screen.

Thanks & Regards,

Bala

Former Member
0 Kudos

Hi,

you need to do same process for both the i-views

former_member283648
Participant
0 Kudos

Hi,

Yes i did for both iViews.

regards,

Bala

Former Member
0 Kudos

Hi,

Check it out by Super User ...........Log in

If its still not working then ............recheck the personlization .

former_member283648
Participant
0 Kudos

Hi,

yes i am doing with super admin access.

regards,

Bala

srinivas_sistu
Active Contributor
0 Kudos

Hi,

Please check which service to be simple iview the UWL is calling when you click on the leave request Approval task. You can do this in two ways.

1. Through SAP R3, by using swfvisu transaction and then goto corresponding task and check what is the iview/webdynpro application it is opening.

2. Go to system administration --> System Configuration --> UWL Administration, then open the XML Configuration of UWL and check what is the iview/webdynpro application is opening when you click on Leave Approve task

Now come back to portal and do the change in the corresponding iview.

Regards,

SrinivaS

siddharthrajora
Product and Topic Expert
Product and Topic Expert
0 Kudos

is the personalisation revelant for all the users? Are you doing this at a admin level? Please checl

former_member283648
Participant
0 Kudos

hi,

Yes i am doing at admin level. it is working fine for leave request screen. But not working for leave approval screen.

regards,

Bala

Former Member
0 Kudos

Go to su01, enter user id you are using for MSS to access UWL. Then try to assign country grouping in the country grouping field.

This might solve ur issue.