cancel
Showing results for 
Search instead for 
Did you mean: 

How to change default selected format for spreadsheet export.

Former Member
132,973

Hello Experts ,

While downloading one report in excel (spreadsheet export ) , I selected one format & also I selected the option " Always use selected format "

Now I want to change that format , but it doesnot take me to the change format screen since I selected the option of always use this format .

How to deactivate this ? I want to select another format .

Thanks in advance.

Abhishek.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member

As mentioned by Mike Kostek, it is working!

1) simply just execute any report,

2) Right click anywhere in the report.

3) Select the "Spreadsheet" from the pop up box.

4) Now you are able to export to Excel with your chosen option

5) Once above action done, the " Always use selected format " shall be turn unchecked!

Former Member

Thanks man for sharing the solution ,

Former Member
0 Kudos

This message was moderated.

Answers (9)

Answers (9)

pnagar
Participant

Hi, One of my User also faced the same issue. They were facing the same in t-codes related to Finance in FBl1n,fbl3n & fbl5n. This is what i did and was able to resolve the issue. I tried T-code fbl3n as below and generated the list as below.

then i went to setting and switch the list to grid as below.

Now after it the output changed to Grid list as below.

Now you could do export directly to Excel as below.

Always remember this problem arises when you select tick mark on below option.

To understand more kindly read about Grid and classic layout in sap.

yaqoobalvi
Discoverer
0 Kudos

On SAP Netweaver 730 It worked for me.

Former Member

Hi!

You need to run program SALV_BS_ADMIN_MAINTAIN (might need to ask someone to do it unless you have authorizations to run programs).

Instructions can be found in this thread in the second last post:

[;

0 Kudos

Thanks ....

Former Member

Try following...

Execute report

Right click anywhere in the report output and select u201CSpreadsheetu201D

A pop up box will appear, select which export option you would like to use and click green check

Exit report and then re-execute report

Choose u201CList -> Export -> Spreadsheetu201D from menu options

Select preferred export option and check u201CAlways use selected formatu201D checkbox and then green check

You should now be able to export to Excel with your chosen option

Former Member

When you are in the line item overview.

Go in the menu to Settings / Switch list

Click with the right mouse button on the context menu (left site top from the list)

2 Select Spreadsheet

Now you get the old menu back that you can select

see SAP note's:

1080608 - Defining ABAP ALV export format for spreadsheet

1065001ALV export XML: Customizing of export options

0 Kudos

i will try and will revert my experience.

0 Kudos

thanks .it's working

Former Member
0 Kudos

Hi Abhishek..

I am facing 1 issue which exporting my report output to Excel..

There are some values which are coming as # .I have to replce it with some String..

The frontend tool which I am using is WAD .There I was able to manage with some JAVAScript but the Excel generated after Exporting it to Excel there it is not reflecting ..

Please let me know if you have any idea about this ..

Any help will be greatly appreciated!!!

0 Kudos

Hi Suraj,

I think this is Excel issue....

can you try to click this ##### , when you click this its shows you the required value.

Mahip

Former Member
0 Kudos

Hi Suraj,

As per Mahip mentioned,That is Excel's issue,
e.g.


the cell shown "####", to solve it, just turn you column width widely:


Hope you understand what I explain....

Rgds,

CHAN K S

Former Member
0 Kudos

Hi Mahip/Chan

Thanks but my issue is somewhat different .I have a report in which I am getting values as # so I have written some JAVAScript there at browser level to replce it with No Applicable Data now when I export it to Excel this JavaScript is not reflecting in my downloaded Excel file and I am getting the # value which should be No Applicable Data .I hope you are clear on the issue...

Please let me know if you have any solution for this..

Regards,

Suraj Grewal

former_member198032
Active Contributor
0 Kudos

Hi,

I believe the following SAP note is what you are looking for too:

https://support.wdf.sap.corp/sap/support/notes/1678355

Hope this was helpful for you.

Regards,

Cristiano

rene_coppens
Participant
0 Kudos

Hi

Use transaction SALV_BS_ADMIN_MAINTAIN

Hope this helps.

Rene