cancel
Showing results for 
Search instead for 
Did you mean: 

How to activating Widgets in B1 Cockpit

Former Member
0 Kudos
3,206

Dear All,

I would like to know that has anyone have experiment in SAP Business One PL12 Cockpit feature? I need help in setting up B1i Server Address for Dashboard's Widgets.

Thank you in advance.

Nghia

Accepted Solutions (1)

Accepted Solutions (1)

Former Member

I've installed sap 8.8 PL12 and afterwards the SAP Integration Solution for B1

Folowed everystep, tested the connections in SDL, everything OK, url in cockpit configuration is correct. But I keep getting the folowing error in the dashboard widget:

404-Not Found

Internal Reason

/com.sap.b1.dashboards/001sap0001.SAP_Dashboard_001.DAB003/default.html

I've tried as mentioned in this thread to deactivate it and reactivate again several times, it doesn't go away.

Do I need Xcelcius for the dashboards to work? (I starting to get lost here.., )

Former Member
0 Kudos

Hello NuNo,

You do not need xcelsius.

Please read the thread carefully and check everything. It should work.

Regards

János

Former Member
0 Kudos

double checked everything...

- SDL test connections says it's everything ok.

- the url in configuration is exactly the same as in the instalation guide pdf (replacing <server name> to localhost and windows machine name getting the same result)

- The checkbox for trusting the server tried both ways checked and unchecked.

The Webserver Tomcat reporting 404 is very wierd.. Tried reinstall, same problem. What am I missing?

Any ideas?

Former Member
0 Kudos

Dear Nuno,

check if the Windows Services SAP DIProxy und SAP DI Proxy Monitor are runnning.

If They do not run, start the services, afterwards deactivate and reactivate widgets.

Former Member
0 Kudos

Thanks for the reply. Yes they are both running, SAP Business One DI Server too.

Former Member
0 Kudos

Hello All,

Question to people who the widget not running:

-Which SQL version are you using?

-Do you have a named SQL instance installed for 8.8 or are you using default instace:

- did you checked the licenses, that has to be applied?

named sql instance example: : (local)sqlexpress, default instance: (local)

Regrards

János

Former Member
0 Kudos

Thanks János,

Now my widget working in the root. I have a problem with the sub instance too.

Pretty nice looking dashboards :).

Nghia

Former Member
0 Kudos

I'm using SQL Server 2008 default instance, all licenses ok.

But.. finally solved! De-activated not only the widgets, but all cockpit, restarted every services, and reactivated cockpit.... SOLVED! finnaly! Hopefully it won't happen again later in the production enviroment

Answers (6)

Answers (6)

Former Member
0 Kudos

Hi All

I have followed all the steps in the post and I get a message now that says The widget is loading or currently not available.

Any ideas

Former Member
0 Kudos

Hi all,

After installing the cockpit, i've got error 401 not authorized, checking into documentation there's the info:

"If the B1i password is not correct or licenses are not properly assigned to this user, the error 401 not authorized will be displayed in the Dashboard widgets.

To fix this, correct the B1i user password in the SLD (system landscape directory) within the Integration Framework and ensure licenses are assigned as specified in section Licenses in this document."

Then i've tried to go in Start > All Programs > Integration Solution for SAP Business One > Integration Framework and got the following message.

"SAP B1iP detected an error:

Emitted HTTP-Code

403 - Forbidden

Internal Reason

XCL198 HTTP-access currently not allowed from remote clients, as B1iP runs in local-mode or safe-mode.

Recommendation

Check for the correctness of your activity or environment or ask your system-administrator for further help."

Checking this thread, i've changed the file Xcellerator.cfg located on C:\Program Files (x86)\SAP\SAP Business One Integration\B1iServer\tomcat\webapps\B1iXcellerator from "xcl.http.localOnly=true" to "xcl.http.localOnly=false" and still got the same message.

I'm running SAP Business One 8.8 PL 12 on MSSQL 2008 with default instance, i've already checked B1i licenses and even tried to turn off cockpit and turn on again...

Someone can help me?

Thanks.

Lucas Sigaki

Former Member
0 Kudos

Did you restarted each B1i Services?

Tomcat will read the new settings if it is restarted....

Regards

János

Former Member
0 Kudos

Thanks János...

I forgot to restart the services.

Now it's working fine!

former_member203816
Active Contributor
0 Kudos

Hi,

I am getting same error.

Emitted HTTP Code

404 - Not Found.

I use all above solution but still i am getting same error.

I use Microsoft SQL Server 2008 with default instance.

I have connect successfully to Integration Component.

Please suggest me how can i solve this problem.

Thanks & Regards,

Tushar Nathwani

Former Member
0 Kudos

Dear Tushar,

If you running widget on local server the security settings can confuse. Try from client side may that help.

Chears,

Nghia

former_member203816
Active Contributor
0 Kudos

Dear Nghia,

I installed on My laptop.So basically it's local machine.

I done everything suggest in this post.

But still i am facing same error.

Please suggest.

Regards,

Tushar Nathwani

Former Member
0 Kudos

I'm also seeing this error:

404 - Not Found

I've followed the troubleshooting guide here: Guide Deleted 31 OCT 2011 - Contained Out of Date Information

What I've been able to determine is that when I check the BizStore Download, I do not see the com.sap.b1.dashboards component listed.

As far as I can see, it's not explained how to fix this in the guide, but only mentioned as something you should check.

Thanks,

Mike

Edited by: Jason Lax on Oct 31, 2011 10:41 AM

Edited by: Jason Lax on Oct 31, 2011 10:43 AM

Former Member
0 Kudos

I´m like Mike Nielsen

10. Check if the scenario exists in the BizStore

 Open the B1iP Control Center -> Maintenance u2013> BizStore Download -> BizStore url click u2026

 In the Choose dataset check if com.sap.b1.dashboards appears in the list

Any idea of what to do.

In this case the cliente connect with the iPhone, with de iPad can´t connect.

But the cockpit it´s always with the error:

SAP B1iP detected an error:

Emitted HTTP-Code

404 - Not Found

Internal Reason

/com.spa.b1.dashboards/001sap0001.SAP_DASHBOARD_001.DAB003/default.html

I´ve tried to desinstall all the components, Flash, Java, Integration Component and Reinstall all the system.

The WSMobile is working, is the cockpit that never works.

Server: 2003 Server

SQL: SQL2005 Standar (With rigth collation)

SAPB1: 8.8 SP00 PL19

Int. Component: 1.0 PL02

Former Member
0 Kudos

Dear All,

i got a similar problem.

Insallation worked, no errors were displayed but when i want to display the Dashboard Widget following message appears:

SAP B1iP detected an error:

Emitted HTTP-Code

404-Not Found

Internal Reason

/com.sap.b1.dashboards/001sap0001.SAP_Dashboard_001.DAB003/default.html [err004]

all Services run

if i check http://localhost:8080 tomcat is also running

where is the mistake ?

former_member377895
Discoverer
0 Kudos

Which address you put in B1i address when enabling widgets in the client setup general ....cockpit ?

Former Member
0 Kudos

Fabian

Everything is fine with your installation.

Check the followings:

When you enabled the wildget, you have 2 checkboxes in the administration (screen is not behind me).

So the 2nd one is under the server address. Set it UnChecked. (this was the solution for me when i got the same error).

Otherwise i hope you have published and activated each dashboards from CocPit manager (tools menu).

Regards

J.

Former Member
0 Kudos

works right now, just deactivated the dashboard 2 times. Don't know why but that solved the problem.

Checkbox under ServerAddress was unchecked.

Fabian Feddern

former_member377895
Discoverer
0 Kudos

Thank you , all working fine now

Marshall-Jones
Participant
0 Kudos

I think I'm at the Same point you are at with the Widgets.

But what I found is that the DI Proxy Service and the EventSender Service - won't run.

If I run the run.bat file in the DI Proxy folder - it will run and the B1iP SID can connect to it.

This is what I'm seeing in the DI Proxy log:

ERROR: 10:04:52: Load the JVM DLL failed

ERROR: 10:04:52: Load JVM dll failed

I'm sure I have the right JVM version 5.0, I've also tried 6.1 with no luck.

Any one else able to get past this?

Marshall-Jones
Participant
0 Kudos

I was able to get past this. I had the right JVM installed, but during the setup I needed to select "Java\jdk1.5.0_22" instead of "java\jre1.5.0_22". The Widgets worked after that.

Former Member
0 Kudos

I have installed it but i get this error:

SAP B1iP detected an error:

Emitted HTTP-Code

403 - Forbidden

Internal Reason

XCL198 HTTP-access currently not allowed from remote clients, as B1iP runs in local-mode or safe-mode.

Recommendation

Check for the correctness of your activity or environment or ask your system-administrator for further help.

-


Full Internal Error Message

XCL198 HTTP-access currently not allowed from remote clients, as B1iP runs in local-mode or safe-mode.

Former Member
0 Kudos

Install >> OK

But exactly same error message ....

Former Member
0 Kudos

Just go to your xcellerator.cfg,

then put the following option : xcl.http.localOnly=false

And it works !!!!

Former Member
0 Kudos

Yes,

In the Administrator's Guide of Integration Component on section 3.1 page 8 is it described, that by default the secutity is enabled only for localhost.

Also in the installation package you can found Technologyia32ProgramExternalContentFrameworkDocs.zip which describes to do on the B1iFW04Operations.pdf.

Right now i am running, but i cannot display any dashboards. They are active, but i reveive the following message:

File not found for any sap deployed dashboards.

Anybody?

Regards,

János

Former Member
0 Kudos

Problem solved, it is working right now.

Regards

J

Former Member
0 Kudos

Dear Janos,

i have already installed 9.1 do i have to reinstall it or is there any other way out?

kindly suggest me...

Regards,

Usman

0 Kudos

Good question.

There isn't too much documentation at the moment.

See here: LINK[https://service.sap.com/sap/support/notes/0001471016?nlang=E]

What I did was set the value of the B1i Server address to be the local PC name.

On startup there is an error stating that the server address is incorrect, but the Widgets work.

What I think is missing is that you can't share the widgets.

Oh, the Service Call dashboard (which I think is flash based and may need Xcelcius) doesn't work.

Edited by: John-Paul Della Puta on Jul 6, 2010 2:43 PM

Former Member
0 Kudos

Hello All,

So basically if you read the document described in the note, you can set up the cockpit, the personal work center.

To turn on the dashboards, no problem:

In the documentation another docu is referenced, SAP B1 8.8 integration installation and setup giude (working with dashboards section)

to download the integration, navigate to than download the B1I

(Updates" SAP Business One 8.8" B1 8.8 INTEGRATION COMPONENT)

in this package you can find the Working_with_Dashboards_in_the_Integration_Component_HU.pdf documentaion in Hungarian language and of course in english. Also find xcelsius files there which are working...

Regards

János

Edited by: János Nagy on Jul 6, 2010 7:40 PM

Edited by: János Nagy on Jul 6, 2010 7:40 PM