Showing results for 
Search instead for 
Did you mean: 

EHS > MSDS > Report status : Generation failed

Former Member
0 Kudos

Hi all,

I have created a report (in CG02) and when I try to release I found the status is Generation failed. Unless the status is Gen. Successful, I cannot release the report.

I found no errors in report template and creation of Gen. variant.

Is it the problem with WWI server? or problem with IMG settings? I find Gen server is up and running. Issue is under high priority.

Can someone help me?


Srinivas Nookireddy

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Srinivas Nookireddy,

  • First check up your WWI server is up and running in CG5z

  • IF not pl check up in CGSADM whether services are running or not

  • Check the services in run mode services.msc , if not restart the EHS services and confirm.

*Please make sure that the programs RC1WWIDP and RC1WWIWP are scheduled and are up and running.

*Also pl check the RFC connectivity in SM59

*Finally check the patch level too.

Sometimes due to temporary network interuption may also lead to this type of generation failed status.

I hope u dont have any problem with DMS part.

Check all the above possiblities and try once again..



Former Member
0 Kudos

Hi Guna,

I am sorry I couldnot update and close the thread for a long time....

Issue is solved; the problem is with CGSADM.


Srinivas Nookireddy

Answers (1)

Answers (1)

Former Member
0 Kudos


Let me think of some possibilities

1. Have you created some documents in CV01N (SBV,SBR,SBE) so that we can be sure that is not a problem with the DMS part? Also try to change the document status network so that you are sure that the network is well defined.

2. If the report is not generated you can check CG5Z WWI Monitor to see if the job has been released, and also you can check that the server is ok (select one line and press Utilities / Test Server)

3. Also you can check that the WWI jobs are running correctly in SM37. Have a detailed view on the WWI Dispatcher job, and you may get some more information on the error

Hope this helps,

Kind regards,


Former Member
0 Kudos

Hi friend,

Thanks for the reply, but the error still remains.


Srinivas Nookireddy

Former Member
0 Kudos

If you think the report does not have errors, then select the report in Report Management and click on Accept (Green check mark). Now check it again and again. Before that make sure you check the generation variant for the validty areas.

Former Member
0 Kudos

Hi EHS Goeroes,

I think I have a simliar issue. I have done the following procedure and settings:

a) Create MSDS report (CG42)

b) Edit Generation Variant (CG2B)


(I have assigned my template to the Generation Variant)

Generate manual request automatically: marked

Change Marks: 0

Initial release status: RE (released)

Version requirement: unmarked

Set historical automatically: unmarked

c) EHS > Specification Workbench > Report from Template (to test the design - display is correct and all phrases can be found)

d) EHS > Specification Workbench > Create new report

(report has been created succesfully and appears in Report Management).

e) EHS > Specification Workbench > Report Management:

MSDS_29 Material Safety Data Sheet for China World

Chinese Not Relevant Generation Poss. => generation possible.

  • Feedback affter clicking on Accept: You tried to carry out action 'Accept' on a report with status GP. However, this action is not allowed for reports with this status.

  • Feedback after clicking on Generate: You tried to carry out action 'Generate' on a report with status GP. However, this action is not allowed for reports with this status.

d) SE38 I have no jobs scheduled yet, so I run the following two programs to start the worklist manually, RC1AVGE1 and RC1AVGE2.

RC1AVGE1 - gave allot of feedback information regarding to changes and so on (first time I run it).

RC1AVGE2 - feedback: EHS: 'Worklist Generation for Reports - Selection for Check. - 0 reports to be checked were found'

From my understanding program RC1AVGE2 - should generate the MSDS.

e) WWI - monitor display (CG5Z):

100 @03\QNo background processes in client@ 5 SBR WWI-00000000000000000002 FREE RMDERKS

110 @03\QNo background processes in client@ 5 SBR WWI-00000000000000000063 FREE A132645

xxx SV001 @5B\QWWI server is active@ @02\QNo background processes on WWI server@

xxx SV003 @5C\QWWI server is inactive@ @02\QNo background processes on WWI server@

I checked if I had any jobs running in the background or has been finished, but it seems like it goes wrong here, the system does not generate a job for the generation of the MSDS_29. To be able to get the status of MSDS_29 to RE (Released).

Does anybody has an idea what I do wrong, or which settings might be incorrect?

Help is much appreciated!

Roy Derks