cancel
Showing results for 
Search instead for 
Did you mean: 

Document is getting saved, but not updating in the data base

Former Member
0 Kudos
2,335

Hi,

We are getting an issue at the time of GRN and Invoice

While saving the GRN document(MB0A) or Invoice, system is generating the successful message of posting the GRN document or Invoice.

But when we are going to check the GRN no in MB02/3 or Invoice no in VF02/3, we are getting message as"No document exist".

Neithor GRN has been posted nor stock moment has been done every time.(Same case with Invoice)

Kindly suggest.

Thanks & Regards

Ritesh Kumar

Accepted Solutions (0)

Answers (9)

Answers (9)

0 Kudos

Hi Ritesh / All

I know that it is a very old post , however I´m facing similar issue.

Were you able to fix it? Please let us know your findings.

Former Member
0 Kudos

Mr. Typewriter,

Below are the notes no:

1793036 Performance bottleneck when selecting data in MM-PUR

1844735 Incorrect data fetch on database table EKPV

1884007 Delivery creation no longer possible using VL10D

1917839 Exception raised during fetching of shipping data

1902763 Exception raised during database fetch on EKPV

1927945 Unable to create replenishment delivery for multiple items

Thanks & Regards

Ritesh

Former Member
0 Kudos

Hi All,

After updating EHP 6.0, We are facing many issue regarding Delivery, PGI,invoice, GRN.

As per discussion with our Abap Consultant,Issue is in updating the VETEG/VEPVG table at the time


of GRN/Invoice.

We are also in the touch SAP support through OSS. We have got 6 notes to implement.

We are doing the same.

Will update you guys what need to be done.

Thanks & Reagrds

Ritesh

Former Member
0 Kudos

This message was moderated.

former_member182378
Active Contributor
0 Kudos

Ritesh,

Thanks for your post!

Could you let us know the OSS note nos.?

sachin_chauhan3
Participant
0 Kudos

Hi Ritesh,

I think i have under stood your problem.

Try this and let me know if you are getting it or not..

- open your invoice under item text do as it is shown in the figure.

former_member184065
Active Contributor
0 Kudos

Hi,

What is the purpose to do this.If I he do what you proposed then how it will be resolved.Please let me know in detail.

Thanks,

Naren

sachin_chauhan3
Participant
0 Kudos

Hello narendra,

one of my friend has also faced this problem.

actually there is a blank space in the text item. which should be remove.

thanks

Sachin

former_member182378
Active Contributor
0 Kudos

Sachin,

Your suggestion is very interesting!

From your experience, in billing doc, at item level, in text, the blank is causing this document not saved in the database.

1. But is space not a character which can be stored as text?

2. How this space flows into the billing document? From the material master, sales text?

Thus if business uses a different material which does not have space in the sales text; then this issue should not come! Correct?

Thanks for sharing!

former_member184065
Active Contributor
0 Kudos

Thanks,

Naren

sachin_chauhan3
Participant
0 Kudos

TW,

Basically i m not the person of SD.  I am an ABAPer.

Our team has also faced this type of error. and they have solved it by the same method i have told above.

and

let Ritesh try it and he will tell us know if it is working or not...

Thanks

Sachin.

Former Member
0 Kudos

Hi All,

After saving the document, We are facing issue as below.

"EXPRESS Document: Update was terminated received from author 'SAP_User_ID' "

Kindly suggest!

Thanks & Regards

Ritesh

former_member184065
Active Contributor
0 Kudos

Hi,

I got same problem as you shared above.

Do one thing,check that user id is having print immediately check mark and Output device settings in "Defaults"tab SU01.

Thanks,

Naren

former_member186385
Active Contributor
0 Kudos

Hi Ritesh,

This is something you have to check in SM13

I hope there could be some issue with your number ranges

please take help of developer to check where  it is giving error, you will get all program details and line number of error in SM13

regards,

santosh

sachin_chauhan3
Participant
0 Kudos

Hi Ritesh,


Check Your number range in T-code  "SNRO"


Regards

Sachin

Former Member
0 Kudos

Hi Ritesh,

There could be an issue with database. Check with BASIS team.

Also, check the number ranges for the invoices.

Regards,

ketan

former_member182378
Active Contributor
0 Kudos

Ritesh,

Is this issue happening for all billing types?

Have you tried creating billing documents with various transactions? (VF01, VF04 etc.) Is the issue happening for all transactions?

After creating billing doc, what does user see in VA03, giving sales order and then document flow?

Former Member
0 Kudos

Mr. Typewriter,

Yes, this issue is getting repeated without having any fix time and Interval.

Invoice is created by VF01, User is getting the proper message of saving the document.

But when we see the document flow there is only PGI has been done against the delivery.

Same issue is happening in the CASE of doing GRN against the delivery.

Kindly suggest!

Thanks & Regards

Ritesh

former_member184065
Active Contributor
0 Kudos

Hi,

I have faced this issue In my case,I have proposed ( ABAPer) to get the automatic print from Invoice it means ,the movement we save the invoice in VF01 then system will automatically show us a pop up box with printer to get the printout of invoice.In my case,I donno ,what he has done to get this but we got problem that the movement we save the billing ,billing number is generating by system and if I execute same number in VF02 then system is saying that document doesn't exist.So,finally ,he has fixed this issue.So,please talk with ABAPer on this issue.

Thanks,

Naren

former_member186385
Active Contributor
0 Kudos

Hi,

Can you check SM13 and see any error log created?

regards,

santosh

Former Member
0 Kudos

Hi,

There is zero log found in "To be Updated" and  "Canceled Process".

Thanks & Reagrds

Ritesh

former_member186385
Active Contributor
0 Kudos

Hi Ritesh,

Do you have any output type assigned to the Billing document type ?

also check OSS note # 175047

regards,

santosh

Former Member
0 Kudos

Hi Santosh,

There is no output type assigned to the invoice.

Thanks & Regards

Ritesh Kumar

former_member223981
Active Contributor
0 Kudos

Are you completely certain about this???? Ensure that you are inputting the correct selection parameters in SM13.

Former Member
0 Kudos

All the data is correct.

0 Kudos

Hi Santosh,

Your answer help me to solve the issue.

BR/Raghava