cancel
Showing results for 
Search instead for 
Did you mean: 

BSIS Missing for G/L accounts

0 Kudos
958

Hi All,

I have a problem. Whan I try to create a document for any G/L account from FB01 or FB60, table BSIS miss the entry and consequently i can't see it in FBL3N.

Instead if I try to create it with customers or vendors, it is written.

Can you help me?

Thanks.


Regards.

EDIT: edited with update.

Accepted Solutions (1)

Accepted Solutions (1)

Refer to note 1323960 for the problem. The note 1437341 contains a report for correct all documents and accounts created.

Answers (1)

Answers (1)

iklovski
Active Contributor
0 Kudos

Hi,

Is your G/L account defined to work with line items? Also, if the document is cleared, you should search for it in BSAS and not in BSIS.

Regards,

Eli

0 Kudos

Hi, How can i check if the G/L account is defined to work with line items?

The documents created is not cleared. When i create any document from FB01 or FB60, the BSIS is not written.

I thought the flag Open Item Management was responsable, but i check in other SAP systems and it work without this flag.

Any idea?

iklovski
Active Contributor
0 Kudos

No, it's not 'open item', but 'line item'. You'll find it in G/L master data 'control' tab.

0 Kudos

Yes, it's flagged.

iklovski
Active Contributor
0 Kudos

Does it happen for specific account or for all accounts? Was this flag changed (you can check it  in 'information cocode' tab in G/L master data)? Do you have missing entries for old documents or also for new created?

0 Kudos

It seems happen for all accounts, both P&L and balance accounts. I don't made any change to accounts, and it happen for old and new documents.

iklovski
Active Contributor
0 Kudos

So, basically, you say that your BSIS table is completely empty?

0 Kudos

mm.. no, there are entries in BSIS.

Excuse me but I'm a developer so I can confuse somethings.

I check BSIS table, the entries was written for DEBI, CRED and GEST Accounts, for all other it seems to be nothing.

iklovski
Active Contributor
0 Kudos

I see... In my turn I couldn't say what you mean by DEBI/CRED/GEST accounts. I believe, it's some of your internal definitions of account groups or field statuses. Anyway, I suggest you to cooperate with FI consultant to check if there is really a problem. Normally, if the account is defined to work with line items, BSIS should be filled. There is no known problem (at least, I'm unaware of it) with this basic table.

0 Kudos

I'm with FI consultant at my side. We are doing many tests.

for DEBI, CRED, GEST i mean all accounts handled automatically (Debitor accounts, creditor accounts, tax accounts..)

iklovski
Active Contributor
0 Kudos

... and for what accounts it does not work then? Can you send a screenshot with the document you are posting in FB50, along with master data screenshot of the relevant G/L account and the document entries in BKPF, BSEG and BSIS tables?

0 Kudos

Here the documents requested.

There are no entries in BSIS.

Thanks in advanced.

iklovski
Active Contributor
0 Kudos

Sono perplesso... BSEG-XKRES is set to 'X' and therefore line items in BSIS are to be created. Try running RFSEPA01 program for this document (you'll have to lock the relevant accounts first). If this does not help, I'd open OSS message.

0 Kudos

Thanks for the suggestions.

I made other tests, I have created a new account without copying it from other. Now it works and create entries in BSIS, but not works for old accounts yet.

I run the report, it created the line in BSIS for the account that not works, but if i do another FB50, it not work again..

I think there is some dirty data in DB, because for new accounts work but not for old.

iklovski
Active Contributor
0 Kudos

Yep, looks like something is wrong with DB, but I couldn't imagine what. Of course, you can try debugging the system checking why BSIS is not filled or the job is not commited.

0 Kudos

Problem resolved.

When we lounched LSMW for get all accounts on system, we used the standard batch input RFBISA00.

This has one field, XLGCLR (present on SKB1). With the batch input, it recorded "/" in this field.

If this field is filled, it replaces the XKRES and XOPVW flags, so it not creates any record in BSIS.

I am amazed of this..

iklovski
Active Contributor
0 Kudos

Wow! Thanks for the update; misteriosi sono i camini del SAP