cancel
Showing results for 
Search instead for 
Did you mean: 

Add-on upgrade to SAP Business One 9.1

Former Member
0 Kudos
160

Hi,

Our customer wants to upgrade their SAP Business One to 9.1 from 8.82.

We created an add-on to support his business requirements using B1DE for 8.82.

Is there any B1DE version for 9.1?

If not, Can we compile this add-on directly in B1 Studio?

If not, Is there any conversion tool available?

Or

We need to do it from scratch using B1 Studio which need considerable time 

Request more information from community on this

Regards

Ajith

Accepted Solutions (1)

Accepted Solutions (1)

ANKIT_CHAUHAN
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi Ajith,

Check the following Blog. You can get the B1DE for SAP 9.1 Here.

Hope it helps.

Thanks & Regards

Ankit Chauhan

Former Member
0 Kudos

Thank you Ankit for your response and I find it useful.

For the time being it will be good to use B1DE 9.1 mentioned in the above link and customer can go ahead with upgrade.

But as SAP does not support B1DE any more, I think moving to B1 Studio will be better.

Is any one tried to convert an Add-on in B1DE to B1 studio?

If Yes, what is the approach we can use? Just recompile/recoding?

Regards

Ajith

edy_simon
Active Contributor
0 Kudos

Hi Ajith,

B1DE and B1Studio is different significantly.

There is no easy way/tools to help you migrate.

Most of the event handling code is still the same, but the event handling is now by Item+Event per procedure compare to one event per procedure.

You have to manually split and move the code by hand.

Regards

Edy

Answers (2)

Answers (2)

Former Member
0 Kudos

Thank you Edy and Thank you Ankit.

Both of you helped us in two different ways.

By providing B1DE link Ankit solved our problem for the time being (Yet to recompile the add-on in new DE)

By giving a correct explanation on how to work on B1 studio, Edy helped us on deciding the future course of action.

Both replies marked as helpful

Thank you once again and Happy new year to all!!!!

edy_simon
Active Contributor
0 Kudos

Hi Ajith,

in SBO 9.1 you can still use the B1DE style of coding.

In term of code wise, no changes are needed.

You need to change the SAPbobsCOM and SAPbouiCOM reference though.

And i am not sure whether you will need to recompile the B1WizardBase to reference the 9.1 DI + UI api.

Also you will need to check the difference between 8.82 to 9.1 a view object in 8.82 is not supported in 9.1 anymore such as the old stock counting object which has changed to a service starting in 9.0

Regards
Edy