Enterprise Resource Planning Blogs by Members
Gain new perspectives and knowledge about enterprise resource planning in blog posts from community members. Share your own comments and ERP insights today!
cancel
Showing results for 
Search instead for 
Did you mean: 
JoergAldinger
Active Contributor
4,965
Hello all,

Since I always find it hard to gather the "right" packages for a fresh install of SLES for SAP Business One, here is a summary of repositories and associated packages required.

The following information was gathered from installing using the "SLE-15-SP3-Full-x86_64-QU2-Media1.iso", however, the same should apply when installing from the "GM" release, or the newest "QU3" release. Packages were validated against the SAP Business One Administrator's Guide, version for SAP HANA corresponding to FP2202 (the latest as of now).

During installation (or after), enable the following repositories, so that you can install the packages they provide:

  • Basesystem-Module 15.3-0

    • bc (not documented, but required)

    • glibc-i18ndata

    • insserv-compat (not documented, but required)

    • libcap-progs

    • libssh2-1

    • nfs-kernel-server

    • python

    • samba

    • samba-client

    • xorg-x11

    • xorg-x11-server

    • zip

    • jq (newly required as of FP2305)

    • noto-sans-fonts (not documented yet, but required as of FP2305 for setup wizard)



  • Legacy-Module 15.3-0

    • libicu60_2



  • Python2-Module 15.3-0

    • python2-pyOpenSSL



  • SLEWE15-SP3 15.3-0 (SUSE Linux Enterprise Workstation Extension 15)

    • python-gtk



  • Development-Tools-Module 15.3-0

    • rpm-build



  • Server-Applications-Module 15.3-0

    • xmlstarlet




If the required repositories are enabled, you should be able to install all the prerequisites with the following one-liner:
zypper in -y bc glibc-i18ndata insserv-compat libcap-progs libssh2-1 nfs-kernel-server python samba samba-client zip libicu60_2 python2-pyOpenSSL python-gtk rpm-build xmlstarlet

If you do need to enable the required repositories after the installation, and have an active subscription or trial code, here are the commands to do so. Note that the Workstation Extension requires a separate registration code. Instead of activating the repositories online, you can use the "Full" media and enable these repositories during installation or from yast2.
SUSEConnect -p sle-module-basesystem/15.3/x86_64
SUSEConnect -p sle-module-legacy/15.3/x86_64
SUSEConnect -p sle-module-python2/15.3/x86_64
SUSEConnect -p sle-we/15.3/x86_64 -r <registration-code>
SUSEConnect -p sle-module-development-tools/15.3/x86_64
SUSEConnect -p sle-module-server-applications/15.3/x86_64

If you plan to only install SAP HANA (2.0 SP05 SPS 056+) on the same machine, the prerequisites are much more simple:

  • Basesystem-Module 15.3-0

    • libatomic1

    • insserv-compat




zypper in -y libatomic1 insserv-compat

Do you have any suggestions? Let me know in the comments!

Best regards,

Joerg.

 
6 Comments
fbio_bilicki
Active Contributor
0 Kudos
Hello, add openssl to install SAP 10 FP2208, is required for B1BackupService-10.0020110-1.x86_64.rpm
zypper install -y openssl

it would be good the next installations of SAP B1 use only python3, I tested on SUSE 15 SP4 and could not install only because of the version of Python.

Python2 has been discontinued in the new versions

Rgs

Fabio
JoergAldinger
Active Contributor
0 Kudos
I never had to separately install openssl, but it is listed in the official requirements (and has been for a while), so depending on what configuration you start with you might have had to add it.

Thanks for sharing.

Regards,

Joerg.
divtech
Explorer
0 Kudos
joerg.ceo, ty for this it is helpful.

Note for anyone else who needs it; the "jq" package is needed in addition to Joerg's list as well for 10FP2305.

zypper in jq

Thanks,
Jaz
JoergAldinger
Active Contributor
0 Kudos
Hello divtechsol

Thanks for the update. I will edit my post to include the package. It's a wonderful package, by the way, which we use a lot for scripting Service Layer tasks, so we generally install it all the time.

Best regards,

Joerg.
andylayphsap
Discoverer
0 Kudos
Dear joerg.ceo , I am currently having a issue on installing "rpm" and "npm-build" library on SLES 15 SP 4. It is showing conflict with "rpm-ndb". I am unable to deinstall "npm-ndb" without messing up the system. May I know what am I doing wrongly? Thank you in advance
JoergAldinger
Active Contributor
0 Kudos
Hello andylayphsap

I'm sorry, but this post specifically refers to SLES 15 SP3. I haven't done any tests with SP4 as of yet, so I can't answer your question unfortunately.

Best regards,

Joerg.
Labels in this area