Devtoberfest Discussions
Join in the conversations with your fellow participants, on anything and everything to do with Devtoberfest!
Showing results for 
Search instead for 
Did you mean: 

Can anyone confirm success with the SAP Business Application Studio tutorials with the free tier?

0 Kudos

... and maybe give a few helpfull hints.

I have sucessfully ‎subscribed  to BTP and followed various tutorials and have gotten to this stage:


Now the Create a Data Model and Expose It as a Service tutorial says "Create a project", from the  Lobby, but I don't find any explanation how to get from the Sap Business Application Studio to the "Lobby".

Can anyone please tell me what is the missing link?

PS. I have tried to create a Dev Space, but didn't make me wiser, so I deleted that again.

PPS. I don't have SAP AppGyver as an application under "Instances and Subscriptions", and I also can't find it in the Service Marketplace. 


Kind regards Thomas



Developer Advocate
Developer Advocate

It looks like there might be a bad link that tutorial. The Link for Set Up SAP Business Application Studio for Low-Code Development seems to instead go to a tutorial for regular Business Application Studio. It should link to this tutorial instead: Set Up SAP Business Application Studio for Low-Code Development in a Test and Evaluation Environment...
That should setup AppGyver which you use to access the Lobby. 

0 Kudos

Thanks Thomas, that makes better sense, but still have a problem.

The tutorial suggest that I run a booster Prepare an Account for Low-Code / No-Code App Development but that does not exist in my BTP trial. I also says prereq. are Low-Code/No-Code entitlements (SAP AppGyver and SAP Business Application Studio. I have SAP Business Application Studio, but no entitlement called SAP AppGyver?


That entitlement was supposed to be available, but it looks like it might have gotten delayed until next month. Apologies. It might not be that you won't be able to complete this particular tutorial (or a small subset).  There are some other AppGyver tutorials this week that can be done on the Community Edition as well.  But don't worry there are lots of activities to make sure you can reach the top goal in the contest. If nothing else, we'll add in a few extra tutorials next week to make up for any missed opportunity here. 


Hi Thomas,

as far as I know AppGyver is not available in a trial account nor is it available as free tier. You would need a CPEA/Pay-as-you-Go Account to create a Subscription for AppGyver. 

Kind regards Dustin 

0 Kudos

Hi Dustin

You might be right, but the first line of Devtoberfest 2022 Contest Official Rules says "NO PURCHASE 💰 REQUIRED TO ENTER OR TO WIN" 

It is quit difficult to win if you can't complete the tutorials 😃


It doesn't require the completion of every activity to win.  In fact, there should be more than enough activities so that only completing about 1/2 of them would still qualify you for the highest tier. 

0 Kudos


I'm not here to win, I'm here to learn - but thanks anyway.
This first week has been awesome  👍 and I'm looking forward to week 2. 
Have a nice weekend everyone. 

Developer Advocate
Developer Advocate
0 Kudos

Sorry for the confusion and not being able to get things working.

I have done this on a trial account, though there is no lobby.

  1. I have an instance of SAP Business Application Studio.  See the tutorial Thomas pointed to:
  2. Open the studio.
  3. Create a LCNC Dev Space. Once the Dev Space opens, its asks for a project name and now you can start using the LCNC tooling for creating a data model.

I was able to do this all just now. If you continue to have issues, let me know. I will update the tutorial.

See all my blogs and connect with me on Twitter / LinkedIn

0 Kudos

Hi Dan

Thank you for your support. The path was a little blurry to me and because I have some browser issue I didn't think I was doing it right, but now I finally succeeded - after I switched browser. 

It is also very confusing that the tutorial mention AppGyver when it is not required to do the tutorial!

Anyway back to my browser problem. I used MS Edge and it was all working very slow and when I have created the project and try to create a data model by pushing the + sign, it did not work - it seemed to be a dead link linkTMNielsen_7-1665304246671.png .

Then I switched to Google Chrome and here everything works. Not fast, but a little faster and the buttons works, so finally I succeeded. 


Kind regards

Thomas Madsen Nielsen