DevOps and System Administration Discussions
Dive into SAP DevOps and system administration. Join discussions to collaborate on optimizing workflows, share knowledge, and leverage resources effectively.
cancel
Showing results for 
Search instead for 
Did you mean: 

TR - Ended with return code: ===> 13 <===

arthur_alvesteixeira
Active Participant
0 Kudos

Hy guys,

I sent a request toa customer and

they imported as a external request.

But the transport log returned witht this message:

Caught signal 11 SIGSEGV (SEGV_MAPERR)

Address not mapped to object (at 0x0000000000000010)

R3trans[T][0x557604fe1776,0x557604fe1776]

R3trans[T][0x557604fe8604,0x557604fe8604]

R3trans[T][0x557604fe129e,0x557604fe129e]

R3trans[T][0x557604db8544,0x557604db8544]

<signal handler called> [0x7f94d6173c70,0x10c70]

R3trans[T][0x557604e12074,0x557604e12074]

R3trans[T][0x557604da346e,0x557604da346e]

R3trans[T][0x557604dfe548,0x557604dfe548]

libc.so.6[S](__libc_start_main+0xf5)[0x7f94d5dde725,0x20725]

R3trans received signal 11 from operating system.

Does anyone knows the reason of this error ?

18 REPLIES 18

warren_angerstein3
Active Participant
0 Kudos

What OS/DB combination? WHat is the output from R3trans -d?

0 Kudos

R3trans -d output:
This is R3trans version 6.26 (release 753 - 29.11.18 - 20:18:11).
unicode enabled version
R3trans finished (0000).

warren_angerstein3
Active Participant
0 Kudos

Also kernel version?

0 Kudos

Kernel version

753_REL patch 400

arthur_alvesteixeira
Active Participant
0 Kudos

Let me check with them....

sriramsbg
Active Contributor
0 Kudos

Hi Arthur.

Transport request created in source and target systems release version are same?

Regards

SS

0 Kudos

Hi Sriram,

Please check this attachment:

version-component.png

JPReyes
Active Contributor
0 Kudos

Hey Arthur,

This is usually an issue with the R3trans version in your kernel, I'll recommend you to update your kernel and try again

Regards, JP

0 Kudos

Hi Juan,

The Kernel version:

753_REL patch 400

arthur_alvesteixeira
Active Participant
0 Kudos

version-component.png

Component version and log details for each component (attached image):

arthur_alvesteixeira
Active Participant
0 Kudos

About the Warren questions,

those are the answers:

R3trans -d output:
This is R3trans version 6.26 (release 753 - 29.11.18 - 20:18:11).
unicode enabled version
R3trans finished (0000).

Kernel version

753_REL patch 400

sriramsbg
Active Contributor
0 Kudos

Hi Arthur.

From the screenshot both system version are different you can't import the change request.

Regards

SS

0 Kudos

Sriram,

The error it's only with Hana Views objects.

Do you think it's possible to import, using request, without an error ?

Thanks

warren_angerstein3
Active Participant
0 Kudos

Since the system levels are different when importing you will have to choose "Ignore Invalid Component Version" under the option screens. I also recomend updating TP and R3trans to the latest.

0 Kudos

Warren,

I did chose this option 'Ignore invalid component error version' but the error continues.

This request (Request A) has 2 object types:

  • Netweaver
  • Hana views

To test I created two requests:

  • Request B - Only with Netweaver objects
  • Request C - Only with Hana Views objects

The request B was imported successfully.

But the request C (Only with Hana Views objects) displays the same error.

Do you think it's possible to import the Hana views, using request, without this error ?

Thanks

warren_angerstein3
Active Participant
0 Kudos

I think you have a 50-50 shot on the hana transport working. On researching the error I saw several people with the same issue that resolved it by upgraded the libsl and kernel. I am not convinced that will help you on this error because the kernel level the system is on isnt that old.

arthur_alvesteixeira
Active Participant
0 Kudos

Warren,

I already saw the 'error 13' issue in this community, but not specifically with the 'Hana view' object in the TR.

  • I thought this error could be fixed without SAP upgrade, because:
  • I already imported, using TR in other two S/4Hana and did work fine.

In the S/4Hana system, where the error occured and does not allow the use the TR, the 'Hana views' can be imported directly on Hana Studio without the version error.

Maybe it can be fixed at another way, like changing a configuration or using SAP Notes, but I didn't find any.

Thanks

sriramsbg
Active Contributor
0 Kudos

Hi Arthur.

Once again both system are different version, you have choose what changes made in the lower version same changes can be done in the higher version not thru change request.

Regards

Sriram