DevOps and System Administration Discussions
Dive into SAP DevOps and system administration. Join discussions to collaborate on optimizing workflows, share knowledge, and leverage resources effectively.
cancel
Showing results for 
Search instead for 
Did you mean: 

Semaphore could not be set while doing client copy

former_member700385
Discoverer
0 Kudos

Hello,

I am trying to do a client copy in a system(S4/HANA 1909 FPS01) and getting the error message "semaphore could not be set - subrc:9. The client copy job runs only for 5 seconds. Has anyone encounterd this before.

The same is the case if I try to delete a client

Screen shot attached

.sccln-error.jpg

Heinz

1 ACCEPTED SOLUTION

alichtenau
Advisor
Advisor

Hi Heinz!

Maybe there is a leftover in table LMSEMAPHORE similar to the issue explained in SAP Note 2705038 (SCCL local client copy gives error : "Could not lock source client"). This can be caused (for example) by a cancelled copy.

Please try to delete this semaphore using DB tools or SE16.

Cheers,
Andreas

View solution in original post

2 REPLIES 2

alichtenau
Advisor
Advisor

Hi Heinz!

Maybe there is a leftover in table LMSEMAPHORE similar to the issue explained in SAP Note 2705038 (SCCL local client copy gives error : "Could not lock source client"). This can be caused (for example) by a cancelled copy.

Please try to delete this semaphore using DB tools or SE16.

Cheers,
Andreas

Thank you Andreas,

You were right to the point. There was a left over from an add on installation where in the final Finish was missing. I did a finish of the same and the entry in the LMSEMAPHORE table got cleared by itself.

After that i could successfully delete the client and start another client copy. It is running fine now.

Thank you so much..

Heinz