DevOps and System Administration Discussions
Dive into SAP DevOps and system administration. Join discussions to collaborate on optimizing workflows, share knowledge, and leverage resources effectively.
cancel
Showing results for 
Search instead for 
Did you mean: 

Authorization error while cloning repository in gcts

0 Kudos

Hi Team,

We are trying to configure gCTS in our system(S4HANA1909/03) . We are getting error 'GCTS.CLIENT.3302: Cloning a repository into a new working directory failed: not authorized' in gCTS app while cloning repository. we are using basic authentication method to connect bitbucket repository. There is no issue if we try to clone repository manually via cmd. Please let me know if anyone has any inputs on this issue.

Regards,

Swapnil

1 ACCEPTED SOLUTION

Karin
Advisor
Advisor

Hi Swapnil,

in SAP S/4HANA 1909 it is required that you set a user and password for the repository. Did you set the parameters CLIENT_VCS_AUTH_USER and CLIENT_VCS_AUTH_PWD for your repository? You can find the documented on the SAP Help portal: https://help.sap.com/docs/ABAP_PLATFORM_1909/4a368c163b08418890a406d413933ba7/99e471efcbee4a0faec82f...

In addition: GitHub stopped supporting log-on via user/password for git operations - you now need to use a token. I don't know whether this is the same for bitbucket

View solution in original post

8 REPLIES 8

Karin
Advisor
Advisor

Hi Swapnil,

in SAP S/4HANA 1909 it is required that you set a user and password for the repository. Did you set the parameters CLIENT_VCS_AUTH_USER and CLIENT_VCS_AUTH_PWD for your repository? You can find the documented on the SAP Help portal: https://help.sap.com/docs/ABAP_PLATFORM_1909/4a368c163b08418890a406d413933ba7/99e471efcbee4a0faec82f...

In addition: GitHub stopped supporting log-on via user/password for git operations - you now need to use a token. I don't know whether this is the same for bitbucket

0 Kudos

Hi Karin,

Thanks for quick reply.

Yes all above mentioned parameters are maintained for repository. In gCTS app log we are getting message 'GLib-GIO-Message: 11:08:37.292: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications'.

As per Al11 repository log, every time system trying to connect git server using token based authentication. we tried to check by removing token from bitbucket but still its pointing to token based authenfication.

Regards,

Swapnil

Karin
Advisor
Advisor
0 Kudos

Hi Swapnil,

I am not a bitbucket expert - but it looks like bitbucket does not support simple passwords any more and you have to enter the token as password: https://bitbucket.org/blog/deprecating-atlassian-account-password-for-bitbucket-api-and-git-activity

Kind reagrds

karin

0 Kudos

Hi Karin,

We tried with token as password but now getting error 'GCTS.CLIENT.3302: Cloning a repository into a new working directory failed: invalid advertisement of <!DOCTYPE html><html lang="en"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><title>Log into Atlassian - Bitbucket Test</title><script>'.

We are trying to clone repositories from bitbucket data center and server 7.21.

Thanks & Regards,

Swapnil Girhe

0 Kudos

Hi,

ok - seems like token is not working for the combination of BitBucket and SAP S/4HANA 1909. You need to use user / password authentication with the configuration parameters CLIENT_VCS_AUTH_USER and CLIENT_VCS_AUTH_PWD

Kind regards

Karin

0 Kudos

Hi Karin,

We tried with user/password authentication with mentioned parameters but still getting error.

if we put repository URL as https://<server url>/users/<user>/repos/<reposname> then getting error 'GCTS.CLIENT.3302: Cloning a repository into a new working directory failed: invalid advertisement of <!DOCTYPE html><html lang="en"><head><meta charset="utf-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><title>Log into Atlassian - Bitbucket Test</title><script>'

and with URL https://<server url>/scm/~<user>/<reponame>.git getting error 'GCTS.CLIENT.3302: Cloning a repository into a new working directory failed: https://<server url>/scm/~<user>/<reponame>.git: not authorized'.

Thanks & Regards,

Swapnil.

0 Kudos

Hi Swapnil,

Since we already have a ticket regarding this on the gCTS component, it would be really great if we can continue the conversation regarding this there.

Best regards,

Sarat.

0 Kudos

Hi Sarat,

Thank you for your help.

After implementing sap note 3194984 issue has been resolved.

Thanks & Regards,

Swapnil.