cancel
Showing results for 
Search instead for 
Did you mean: 

Why created facet is not appeared for some categories?

0 Kudos

Why created facet is not appeared for some categories?

Hi.

I am very beginner for SAP and SAP commerce cloud, and currently I am studying for SAP Commerce Cloud business user - Adaptive Search.

And now I started to study Adaptive Search - Adding Facet based on below video, and tried the same in my training server.

https://microlearning.opensap.com/media/Adding+a+New+Facet+to+the+Storefront+-+SAP+Commerce+Cloud/1_...

I followed the exactly the same as in video, and sure that for SOME categories and for some keyword search, the 'stockLevelStatus' facet set in Online version of Electronic site with Electronic Solr Index appeared.

But for some - not.

I have set this in global categories only. Why this is not applied for all category and keywords?

Here is what I set:

At BackOffice - Adaptive Search:

Navigation Context:

Index Configuration - 'Electronics Solr Index'

Index Type - 'electronicsProductType'

Catalog Version - 'Electronics Product Catalog: Online'

Search Profile - 'defaultElectronics - Category Aware'

Categories: 'Global'

#Created Facet;

Index Property: stockLevelStatus

Facet Type: Refine

Priority: 20000

Facet Values/Administration tab - default setting (almost blank)

#What I confirmed;

with keyword search 'e', 'd' - 'stockLevelStatus' facet is displayed.

with keyword search 'dd', 'easy' - 'stockLevelStatus' facet is NOT displayed.

Without any keywords/at 'BRANDS', 'DIGITAL CAMERAS' categories, 'stockLevelStatus' facet is displayed.

But any other categories, 'stockLevelStatus' facet is NOT displayed.

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hi, sorry.

I checked below similar question and answer, and self-resolved this.

https://answers.sap.com/answers/12781987/view.html

-> When I updated 'Facet Configuration' - 'Facet Type' from 'Refine' to 'Multi-Select OR', then, regardless of category, it has appeared - it worked as 'Global' level as I intended.

Thanks.

Answers (0)