cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to run unit tests with Mockito and Power Mock on SAP Commerce Cloud v2011

jguerrom
Member
0 Kudos

After migration process from SAP Commerce Cloud Infrastructure v6.6.0.x to SAP Commerce Cloud Public Cloud v2011 we are unable to run unit tests using Mockito and PowerMock

We have tests that use PowerMock to test static code but its not compatible with the current Java/Hybris versions (Currently using Java 11) and we cannot upgrade Mockito to the latest version to use as a tool to test static code because the old version of this lib is imported by OOTB code (Mockito version: 1.10.19).
The above causes all test source build to fail on any module we have tests with static code (using PowerMockito)

Is there a correct way to update OOTB Mockito lib?

Accepted Solutions (0)

Answers (0)