cancel
Showing results for 
Search instead for 
Did you mean: 

SAP Hybris - Error: "npm install" encountered an error

rrajabe83
Member
0 Kudos

Hi Team,

Am getting below NPM install error when doing ant all in SAP Hybris 2205 suite. I already installed node.js but still the error persist. Please help me if anyone have answer.

[exec] Transforming C:\Project\Hybris_2205\hybris\bin\modules\smartedit\smartedittools\common\config\rush.npmrc [exec] --> "C:\Project\Hybris_2205\hybris\bin\modules\smartedit\smartedittools\common\temp\install-run@microsoft+rush@5.62.4.npmrc" [exec] Installing @microsoft/rush... [exec] [exec] [exec] Error: Unable to install package: Error: "npm install" encountered an error [exec] [exec]

BUILD FAILED C:\Project\Hybris_2205\hybris\bin\platform\build.xml:13: The following error occurred while executing this line: C:\Project\Hybris_2205\hybris\bin\platform\resources\ant\compiling.xml:95: The following error occurred while executing this line:

-----------------------------------------------------------------------------------

I tried to run the SSL command like below but no use.

**C:\Project\Hybris_2205\hybris\bin\modules\npm-ancillary\npmancillary\resources\npm\node

npm set strict-ssl false

npm cache clean --force

npm config set strict-ssl false**

Accepted Solutions (0)

Answers (0)