cancel
Showing results for 
Search instead for 
Did you mean: 

Minimum spartacus version compatible with SAP Commerce Cloud 2211

swapnasap
Explorer
0 Kudos

The sap and spartacus sites say Spartacus 3.3 or above is needed for SAP Commerce Cloud 2205. Does this hold for SAP Commerce Cloud 2211 too? Could not find this information on the SAP sites.

Accepted Solutions (0)

Answers (1)

Answers (1)

safin
Advisor
Advisor

Hi Chirra,

Currently, the latest documents in Spartacus only shows the installation instructions for 2205 at https://sap.github.io/spartacus-docs/installing-sap-commerce-cloud/, the Spartacus version is 4.3.*

On the other hand, starting with version 5.0, “SAP Commerce Cloud, composable storefront” is the name for the official release of project “Spartacus” libraries published by SAP, which need at least 2105 or newer version of SAP Commerce Cloud.

As of your question, the minimum Spartacus version compatible with SAP Commerce Cloud 2211 should be Spartacus 5 (composable storefront), you can refer to https://help.sap.com/docs/SAP_COMMERCE_CLOUD_PUBLIC_CLOUD/12be4ac419604b01aabb1adeb2c4c8a2/24fc60715... for more information

swapnasap
Explorer
0 Kudos

Thanks for your reply, but as per the SAP documentation Installing SAP Commerce Cloud 2205 for use with Spartacus - Spartacus Documentation it needs only 3.3 or higher of Spartacus. Am looking for information for 2211 compatibility with earlier spartacus versions.

safin
Advisor
Advisor
0 Kudos

Yes, for 2205, it can also work with Spartacus 3.3 or higher, but for 2211, there is no official document to say it support Spartacus 3 or 4. In technology, it is possible to have Spartacus 3 or 4 to work with 2211, but officially, 2211 will work with composable storefront, 🙂

phy_abhijit
Explorer
0 Kudos

We have upgraded recently Commerce cloud to 2205 which is compatible both with Spartacus 3.4 version as well as Spartacus 4.3 version. As part of the project, we upgraded Spartacus 3.4 to 4.3 version and we didn't find any issue to run portal.

ahmad_khan1
Discoverer
0 Kudos

Hi Abhijit,

We are using spartacus 3.4.10 and nodeJS 14 with SAP CC 2011.

And recently upgraded SAP CC v2011 to v2205 however did not upgraded Spartacus.

Now we are facing issue that the web pages getting loaded are blank. Not sure if we need to upgrade Spartacus as well?

Any sugesstion will be appriciated.