cancel
Showing results for 
Search instead for 
Did you mean: 

Issue integrating SmartEdit - SAP Commerce 2205 with Windows

swollmershaeuser
Explorer
0 Kudos

Hello,

I need to add SmartEdit to our current project.Therefore I added the required extensions from https://help.sap.com/docs/SAP_COMMERCE/9d346683b0084da2938be8a285c0c27a/0955af7dd5154a8db28dfce327d8... (without the addon)

Sadly I run into the same problem like here:

https://answers.sap.com/questions/13497106/isuue-installing-sap-commerce-2105-with-windows.html

https://answers.sap.com/questions/13569524/sap-commerce-21056-pnpm-install-failing.html

Error:

     [exec] Progress: resolved 1852, reused 1849, downloaded 0, added 1762
     [exec] Progress: resolved 1852, reused 1849, downloaded 0, added 1847, done
     [exec] .../core-js@3.6.5/node_modules/core-js postinstall$ node -e "try{require('./postinstall')}catch(e){}"
     [exec] .../core-js@2.6.12/node_modules/core-js postinstall$ node -e "try{require('./postinstall')}catch(e){}"
     [exec] .../es5-ext@0.10.61/node_modules/es5-ext postinstall$  node -e "try{require('./_postinstall')}catch(e){}" || exit 0
     [exec] .../node_modules/@nestjs/core postinstall$ opencollective || exit 0
     [exec] .../es5-ext@0.10.61/node_modules/es5-ext postinstall: Failed
     [exec] ÔÇëELIFECYCLEÔÇë Command failed with exit code 1.
     [exec] .../core-js@3.6.5/node_modules/core-js postinstall: Failed
     [exec]
     [exec] The command failed:
     [exec]  C:\Users\...\hybris\server\hybris\bin\modules\smartedit\smartedittools\common\temp\pnpm-local\node_modules\.bin\pnpm install --no-prefer-frozen-lockfile --strict-peer-dependencies
     [exec] ERROR: Error: The command failed with exit code 1
     [exec]
     [exec] Giving up after 3 attempts
     [exec]
     [exec]
     [exec] ←[31mERROR: The command failed with exit code 1←[39m
     [exec] ←[31m←[39m

BUILD FAILED<br>

Workaround did not help.Did try several node/npm versions.

Currently:

node: 14.17.6 npm: 6.14.15.

What can I do? Did i miss something for the workaround? And why is this still a problem in the next version?

emarcon
Discoverer
0 Kudos

Hi Svem,

same problem. Have you found a solution? Thanks.

Accepted Solutions (0)

Answers (2)

Answers (2)

gaurav11
Participant
0 Kudos

Hi Sven,

You can try below step.

  • Clear the npm cache: A damaged npm cache may occasionally be the source of problems. Cache clearing may be beneficial. To remove all of the npm cache, enter the following command: npm cache clean --force
  • Retry Installation: Try the installation again after deleting the cache: pnpm install --no-prefer-frozen-lockfile --strict-peer-dependencies
  • Firewall and network difficulties can occasionally prevent packages from downloading. Make sure your network connection is steady and that npm can get the necessary packages without being hindered by a firewall or proxy.

Thanks,

emarcon
Discoverer
0 Kudos

I finally found a solution, it's necessary to check the npm lib versions, from bin/platform execute:

ant rushcheck -Dpath= absolute_path_of_smartedittools_module

fix all the wrong npm lib versions in package.json and then recompile using:

ant clean all

Regards,

Ettore.

0 Kudos

Hi Ettore,

I'm using hybris 2205 version, can you provide me what are all the version required to be set?

Thanks